Cancel
Showing results for 
Search instead for 
Did you mean: 

New version of lisence with an old version of the program

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hello!

 

I been working with the program for years and I always heard that the newest version of the lisence runs for older versions of the program.

I had tried it with the ST10 lisence in the ST9 program and with the ST9 lisence in the ST8 program.

It is true or just a chance?

 

And, if it is true, which versions will run with the ST10 lisence?

 

Thank you!!

18 REPLIES

Re: New version of lisence with an old version of the program

Siemens Phenom Siemens Phenom
Siemens Phenom

Yes, this is correct.  The license file is downward compatible.  If using floating licenses the daemon is only downward compatible to IIRC ST4.

Betreff: New version of lisence with an old version of the program

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @BeatrizSeoane

 

 

I have done this many years without any problems.

When a new version is coming out, I install it on a single machine for testing.

At the same time (or better to say before) I change the license file on the license server - what can be done with running server and no stop - change the license file, do a reread, and from that moment on everybody can use the new license (for my test machine) together with all older versions of SE downwards until ST4.

 

There was a break between ST3 and ST4 with the FlexLM 

 

From ST3 downwards You can start any version till - this is what I remember v11 - but maybe further more.

 

 



regards
Wolfgang

Betreff: New version of lisence with an old version of the program

Siemens Phenom Siemens Phenom
Siemens Phenom

Just to clarify, you cannot drop a new ST10 floating license into an existing ST9 floating license setup.  ST10 floating license will require you to install an updated version of the FlexLM software on your license server before you will then be able to use your ST10 floating license with ST10 and ST9 or below.

Betreff: New version of lisence with an old version of the program

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @uk_dave

 

 

thanks for clarifying this.

 

I was aware about and we have done this upgrade already.

 

I thought that the reinstallation of FlexLM on server was mentioned so often, that there is no need to talk about it again.

Sorry!

 



regards
Wolfgang

Betreff: New version of lisence with an old version of the program

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hi!

 

Thank you for the response.

 

Just one more question; If i have a server with a software of 32 bits. There is any way to install the license administrator of the ST10 there?

I know that it is not supported but i know in the oldest versions it was possible. I have clients that worked with ST9 with the lisence administrator of the V20 to run it with the x32 bits system.

There is any way to do the same with ST10??

 

Thank you!!

Betreff: New version of lisence with an old version of the program

Siemens Phenom Siemens Phenom
Siemens Phenom

From the Solid Edge readme file:

 

Solid Edge License Manager Operating System Information

FlexNet Publisher 2016 (11.14.0) supports the following:

  • Windows 10 (32-bit or 64-bit)
  • Windows 8 (32-bit or 64-bit)
  • Windows 7 Ultimate (32-bit or 64-bit)
  • Windows Vista Ultimate (32-bit or 64-bit)
  • Windows Server 2008, Windows Server 2008 R2, Windows Server 2012 (64-bit), or Windows Server 2012 R2 (64-bit)

Betreff: New version of lisence with an old version of the program

Valued Contributor
Valued Contributor
I'm having issues getting Flexnet updated to work with the new ST10 license. Is there a way to do this without removing the old license as it really limits when I can attempt the upgrade and ensure I keep us productive with ST8?

I've uninstalled the old SE license manager, installed the new one and tried to get the new license file working but it kicks back errors. I've had to revert back to the older version.

License server is Windows Server 2008 R2

Thanks,
Guy

CAD/CAE Manager
ST8 MP12

Betreff: New version of lisence with an old version of the program

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Guy_H77

 

The current FlexLM server with the ST10 license should work for ST8 too.

If You say,  You got errors, can You tell what messages there are?

 

 



regards
Wolfgang

Betreff: New version of lisence with an old version of the program

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

Two possible errors here.

 

1) The FlexLM server.  We had a similar problem to what you are describing.

1a) Did you update the FlexLM server?  The ST10 license file requires the latest version of FlexLM to work.

1b) Even after we updated the FlexLM software, we still had errors.  With a little support from FlexLM, it ended up being a corrupt log file.  Delete the log file and try again.

 

2) The client installations.  Each client can run old versions of Solid Edge, but the license files either have to match or the license file has to have the USE_SERVER switch.  If you haven't modified the client licenses to include the USE_SERVER, then you will have to load the ST10 license file on all of your ST8 boxes once the ST10 license is live on the FlexLM server.


____________________________________
--Scott Wertel, P.E.