Reply

PDF Printer

Hi everyone,

 

My pdf printer is broken or not working anymore. I cannot print 2d pdf's anymore with the build in pdf printer.

Is there a way to un/reinstall repair the pdf printer without the need to reinstall the complete SE installation.

Any help would be much appreciated

 

Dirk

 

Dirk Rutten

Solid Edge STX user
5 REPLIES

Re: PDF Printer

Hi,

 

Have you tried running PrinterInstaller.exe from the Program folder ?

This should hopefully solve the problem.

 

BR,

~Tushar

 

Re: PDF Printer

Hi Tushar,

 

Sorry for the delay...and thank you...

But I just have done what you said without any luck.

I do get the following message when I make a 2D pdf out of a draft file.

 

gswin32c.exe does not work anymore...

 

I can Use an external pdf printer to make pdf files. But I would prefer to use the internal pdf writer for this.

Is there no tweak possible in the registry ?

 

Any help would be much appreciated.

Dirk Rutten

Solid Edge STX user

Re: PDF Printer

BTW I need to thank you for something else also... The macro's you did make last week or so, are great !
I'm glad that beside Jason N and a few others, there's another one willing to share his work here in the SE forum.
Dirk Rutten

Solid Edge STX user

Re: PDF Printer

Hi Dirk,

 

  The workaround about PrinterInstaller pertains to the Save As PDF command which I mistakenly had in mind all the time.

  Not sure if it will help fix the Solid Edge Velocity printer issue you are facing.

 

  Have you tried the built-in 'Save As PDF' command instead of using a third-party PDF printer. The command should still be working fine even without applying the workaround.

 

 

 

 

Re: PDF Printer

Dirk,

 

About the gswin32c.exe error, GPL Ghostcript is an interpreter for the PostScript language and for PDF displays, print and convert PostScript and PDF files.

 

Solid Edge also perhaps uses this for converting and printing to PDF, possibly the latest version - this is just a guess.


If you installed a PDF freeware, it doesn't have that protection to announce you that you  already have a newer version.

You can manually clean the registry from:
HKEY_LOCAL_MACHINE\SOFTWARE\GPL Ghostscript


Then run the PrinterInstaller again. If it still does not help and you don't want to re-install
Solid Edge all over again, download the latest GPL GhostScript from:
http://sourceforge.net/projects/ghostscript/files/GPL%20Ghostscript/9.01/gs901w32.exe/download
or the latest version from the official site here:
http://ghostscript.com/download/

 

I haven't tried this yet, so tweak the registry at your own risk.

 

~Tushar