Cancel
Showing results for 
Search instead for 
Did you mean: 

Part does not appear in assembly properly

Creator
Creator

Hello,

 

I have a part that is made up of part copies.  It was likely converted from an .STP file.  Every part copy has a purple symbol next to it except for Part Copy 45, which has a silver icon. When I insert this part into any new assemblies, Part Copy 45 does not show up.  What does the silver icon mean, and how can I make the entire Iota One file appear in new assemblies? The part file may be found here: https://drive.google.com/file/d/1DoNo03O6SW93lMeFAcQoiGpSCWEMV4bN/view?usp=sharing.  I've already tried optimizing the part.  Thanks,

 

- Aviv

 

 

9 REPLIES 9

Betreff: Part does not appear in assembly properly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Aviv 

 

 

so what You see here is a "Construction Body" rather than a "Design Body"

A Construction Body consists of surfaces and will or can not build a closed volume with material.

What man can see too here, is an import which more or less is an assembly and not a single part.

Yes of course You can import an assembly into a multibody part too, depending on what it is need for.

 

If this is only for showing You can show the surfaces of that part in the assembly too (RMB show/hide) 

 

If it should be a real part, YOu have to check and to heal that surface so it can build a closed volume too.

 

 

regards
Wolfgang

Re: Part does not appear in assembly properly

Siemens Phenom Siemens Phenom
Siemens Phenom

Part Copy 45 is a surface.  You will need to display surfaces once you place the file in to your assembly in order to see this feature.

 

P.S.  No point providing a link to the file on Google Drive if you have access restricted. 

Re: Part does not appear in assembly properly

Siemens Phenom Siemens Phenom
Siemens Phenom

@hawcad Snap!  You beat me to it :-(

Re: Part does not appear in assembly properly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@Aviv Part Copy 45 is a surface which are not shown by default.  In the Assembly, right click on the component and select "Show/Hide Component..." and turn on the Surface option.



Ken
Production: SE 2019 MP8, Testing: SE 2020
http://Grundey.blogspot.com

Re: Part does not appear in assembly properly

Siemens Phenom Siemens Phenom
Siemens Phenom

@KennyG too slow! ;-)

Re: Part does not appear in assembly properly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@uk_dave  schrieb:

@hawcad Snap!  You beat me to it :-(


 

 

Hi @uk_dave 

 

 

I'm sooooo sorry!

 

Smiley Wink

regards
Wolfgang

Betreff: Part does not appear in assembly properly

Creator
Creator

Thanks very much everyone, this was my first post. If I wanted to heal the surfaces and convert them to a solid so that I can constrain the new solid, how would I go about doing that? 

 

Also, here is the part link (unrestricted):  https://drive.google.com/file/d/1DoNo03O6SW93lMeFAcQoiGpSCWEMV4bN/view?usp=sharing

 

 

Betreff: Part does not appear in assembly properly

Creator
Creator
Never mind, just realized I could constrain surfaces as well. Nonetheless, where is the "healing" tool?

Betreff: Part does not appear in assembly properly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

HI @Aviv 

 

 

 

there is no single "Healing Tool" in SE, first - but I think You have done this already - is to run the Gemotry Optimize tool from the "Inspect" tab.

But if there are missing surfaces, etc. to close that "part" (body) it will or can not create a closed solid body at all.

Then You need to inspect this body fo ropen boundaries (areas) and if necessary, You have to create extra surface to close that area.

 

I can not give You a single push button solution to that, this has to be considered from case to case.

 

 

regards
Wolfgang