Showing results for 
Search instead for 
Did you mean: 

Placing a part in an assembly


What am I missing.
I haven't work on SE since 2004 but now started a new job where I need SE.
Sure it looks different but sould work the same.

My problem is I can drag parts into an assembly but can't seem to mate them with other parts.
Keep getting the same error.
"The requested relationship conflicts with others and cannot be placed"
There is no other relationships yet so how can that be?

I even tried to work through the tutorial where they assemble a micrometer.
Dragging the parts in from the training folder is easy but I cant mate them.
Am I doing something wrong or am I missing some crucial step?

Re: Placing a part in an assembly


Please post a screen shot of what you are trying to assemble. This will help get a better idea of what we are working with. In the mean time. try the options below.


Try dragging the parts in.

Hit escape twice to ensure you are out of any other command.

then manually pick the relationship you want.

select the faces and see it the same error occurs.

The part you are bringing in might have some "capture fit" items set.

If you escape and manually go back in to the assemble command this will ensure you are starting fresh


Hopefully this helps.

Cory M
Solid Edge ST10
ST10 Cert

Re: Placing a part in an assembly

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Which version of Solid Edge are you using?  Are you using the Solid Edge standard templates?


I have heard of a similar issue with a workaround detailed below.


***Please note to be careful when editing registry keys***


Siemens PLM believes that the problem you reported where Parts cannot be added after change to ST10 will be resolved in Solid Edge ST11.
For ST10 MP3 use following Registry Key as workaround:
HKEY_CURRENT_USER\Software\Unigraphics Solutions\Solid Edge\Version 110\DEBUG
Add the key "NumericalSolveOff" (32 bit DWORD) and set to 1 to place additional parts.

Re: Placing a part in an assembly

Esteemed Contributor
Esteemed Contributor

A user here just inexplicably got that same error on a newly inserted part. We first tried closing and restarting SE with no solution. Next we rebooted the machine. Fixed.

Bruce Shand
ST10 MP5 - Insight - Win10 - K4200

Betreff: Placing a part in an assembly

Esteemed Contributor
Esteemed Contributor

HI Edgers,

i just have seen the same problem today at a customer site, also running ST10 with MP3 under Win10.


I inserted several parts to a small assembly (5 existing parts) and was not able to create an axial align just as first relation.

Always got the error that the relation can not be placed, although there was no other relation existing so far.


I - as trained in many SE years did known first steps.

Closing down SE, starting new, but without any difference.


Next approach, I thought that the part had a problem - even if it only was a thin plate with two holes in it.

I tried a different part and - Yes - same problem.


During this training I have seen this behaviour/problem on several computers by several users.


One of them has found an approach to get it anyway, and this was to stop the placing, start relation and use the same reference axis BUT the other way round.

First select the axis from the already placed and fix part and then select the axis from the new inserted part.


Wow, that worked.


But IMHO this seem sto be a big bug by ST10MP3!