Replace Face bug

Esteemed Contributor
Esteemed Contributor

There appears to be a bug wherein some radii on a changed part are removed. I submitted an IR. See attached.

p.s. these are not frame members

 

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200
7 REPLIES

Betreff: Replace Face bug

Honored Contributor
Honored Contributor

Hi Bruce, @bshand,

 

 

 

Yes this could beconfirmed here.

Same results after "replace face"

 



regards
Wolfgang

Re: Replace Face bug

wow,  totally not cool!!!

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX10 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.6

Re: Replace Face bug

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

Hello,

 

If you're doing this in ordered, does it matter if, in your part, you roll back to a point before the radii are added and perform the replace face command? 

 

Kyle

Kyle Joiner
IPA LLC
ST10 MP1

Re: Replace Face bug

Phenom
Phenom

This also happens in ST7

HP Z420 16GB RAM
Quadro K4000
ST7 MP10 on Windows 7 Pro 64.

Re: Replace Face bug

Esteemed Contributor
Esteemed Contributor

@kjoiner, This is replace face in assemblies.

Edit: Actually, in the options dialog in the replace face command if you choose to do it in ordered the error doesn't occur. So it only applies to sync.

@beachcomber. Re[ace face in assemblies is new to ST9.

I should have said "in assemblies" explicitly.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: Replace Face bug

Phenom
Phenom

@bshand

Yes, I realised the method you were using must be new in ST9, but the problem still occurs in ST7 with sync parts where you have to perform the replace face in the part.

There isn't a problem in ordered when you do an insert part copy of the trimming faces.

HP Z420 16GB RAM
Quadro K4000
ST7 MP10 on Windows 7 Pro 64.

Re: Replace Face bug

Esteemed Contributor
Esteemed Contributor

Thanks for clarifying. I never used replace face until recently. So I wonder if its sync problem at the part level was ever reported.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200