Reply

SETTINGS & PREFERENCE WIZARD ISSUE

[ Edited ]

I've used this tool various times and usually after clicking the boxes I want then "finish" it loads the files and (if I remember right) it says all files were deployed and either closes or asks to close?

My issue is I'm installing ST10 so I saved my preferences successfully, installed ST10, then switched to cloud licensing. Everything has worked fine, ST10 opens perfect,  but the settings & preference tool won't deploy my settings. The command window is abnormally slow as well, takes 5-10 seconds to identify a checked box, then upon clicking finish it basically does nothing, even after waiting for 4-5 minutes as well as a reboot. I assumed I could load the settings then upon logging into cloud save them.

any ideas here?  ST9 to ST10 no worky? or?

 

Thanks Craig

7 REPLIES

Re: SETTINGS & PREFERENCE WIZARD ISSUE

[ Edited ]

Maybe the S&P wizard was set to save registry settings as well as custom menus so that now it's messing with the registry? That's admittedly a WAG.

But if you still have the customization folder in appdata save the newest theme xml files then refer to them when picking a theme for ST10?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: SETTINGS & PREFERENCE WIZARD ISSUE

I at least got this now..setting issue.jpg

Re: SETTINGS & PREFERENCE WIZARD ISSUE

Seems like an extremely helpful message.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: SETTINGS & PREFERENCE WIZARD ISSUE

If only the hidden meaning was decipherable.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: SETTINGS & PREFERENCE WIZARD ISSUE

 

Your user settings are Solid Edge version specific, therfore  I would not expect there to be any method in the tool to "upgrade" (or even downgrade) your preferences from one major version to another.

 

TBH, I would not want to carry over any preferences from an older version into a newer version.  There are always differences in the UI, regsitry keys, etc. between major versions.  Why would I want to carry over something legacy from ST9 that may have been replaced or optimized in ST10.

 

 

Re: SETTINGS & PREFERENCE WIZARD ISSUE

Not even custom menus?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: SETTINGS & PREFERENCE WIZARD ISSUE

Your theme settings are stored in a folder that is still version specific.  If you want to get these from ST9 to ST10 I would manually copy the desired themes folder into the ST10 folder through Windows Explorer, launch ST10 and make sure it is working as expected.  Once your settings have been fully updated manually to ST10, then I would expect you to be able to use the Settings and Preferences wizard to share/move your Solid Edge preferences around without issue.  However, there are still changes made in the UI between versions.  Do you really want to carry across ST9 UI elements into your ST10 settings?

 

This activity is not unexpected -- there are always activities required to ensure that everything is properly updated to the latest Solid Edge version.  For example, you should always open your Solid Edge template files and save them back in the new version.  Same thing with the SEAdmin Options xml file.  I would expect preferences and settings to be no different.