Reply
Solved! Go to solution

ST10 - Any Feedback on Installation and Use, Please

Sorry for asking, offcourse reading the forum a few times a day, but still.

I need to start a new mid size project tommorow in Solid Edge and do not want to have any delays.

Using Solid Edge for about 20 years, SolidWorks Premium for about 11 years, both with the continuing maintenance, currently ST9 MP8 floating license and SW2017 SP3 on W10 Pro and W7 Ultimate without any problem.

Often using Settings and Preferences Wizard to save settings changes. Will do single version clean install and perhaps install ST9 settings back on ST10 - any opinion on pushing ST9 wizard settings on?

Other potential problem is possible too many changes in ST10 API VBA coding, which I use a lot in my AAA ERP.

Thanks.

 

Milan Wendl, MEngSc, P.Eng.

AAA Engineering

Canada

 

Milan Wendl, MEngSc, P.Eng.
AAA Engineering, Canada
ST10, SolidWorks Premium 2017
10 REPLIES

Re: ST10 - Any Feedback on Installation and Use, Please

Hi there @milanw,

 

I have installed fresh [no S&P Wizard], and have been straight into production designs & drafting work with ST10, as though it were ST9 w/MP8, and have had no issues over the past few days......if anything, it's a bit better with graphical response, on my aged Surface Pro3, in some previously slower assemblies.

 

Not had any free [or less pressured] time to try out some of the shiney bit, of particular interest, the new Generative Design tool will be in first place.

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP0] Classic [x2 seats]
Windows 10

Re: ST10 - Any Feedback on Installation and Use, Please

Hello Sean,

Thanks for your info and time.

Milan Wendl, MEngSc, P.Eng.
AAA Engineering, Canada
ST10, SolidWorks Premium 2017

Re: ST10 - Any Feedback on Installation and Use, Please

I've gone to ST10 it appears quicker but I've already had a few crashes for no apparant reasons.

For me there are no 'bells and whistles' especially after finding out Tec Pubs isn't avaiable. Sewing machine designers may find it more exciting. I wasn't a fan of version 9 so wanted it off my PC asap so installed V10.

Re: ST10 - Any Feedback on Installation and Use, Please

Some installed ST10 Monday and the rest installed yesterday.  A couple things to note for floating licenses. 

1) You will need to install the new Flex License Manager.  The previous version(s) will not work.  However, this should be mostly painless to do.  We thought we would have to reboot our server mid-day when we installed it but got lucky and did not need to.

2) The Settings and Preferences did not work for us.  We tried to bring them in from ST9 and no one was successful.  So, instead I made a new file within ST10 to get some basic settings set and everyone used that instead successfully.  They then had to make the rest of their personal modifications themselves.  

 

So far, no real problems.  One person was trying to mate a part to an assembly and it would not let him select any mates.  It was a part created from a dxf file, once finished creating it, he had the assembly and the part open and dropped the part into the assembly at which point he could not mate it.  He closed Solid Edge and reopened and the problem went away.  He tried to reproduce it by retracing his steps and has not been able to.  So other than that small hiccup, no problems.  

 

We are also unmanaged btw.

Brian Fritz
Solid Edge Certified Professional
ST10 latest MP

Re: ST10 - Any Feedback on Installation and Use, Please

Thank you all very much for your posts and help.


I am running ST10 now. Did do the clean install using Solid Edge tool, manually deleting some windows leftover folders, going thru the relevant registry cleaning manually etc.


After the install, ST10 did pickup my custom dimensioning, and other formally saved setting, such as menu ribbons, which was really good. Off-course did update code references in my AAA ERP, than checked its main Solid Edge functions. So far all good.


Thanks.

 

Milan Wendl, MEngSc, P.Eng.

AAA Engineering, Canada

Solid Edge ST10, SolidWorks Premium 2017 SP3

Milan Wendl, MEngSc, P.Eng.
AAA Engineering, Canada
ST10, SolidWorks Premium 2017

Re: ST10 - Any Feedback on Installation and Use, Please


Fritz wrote:

2) The Settings and Preferences did not work for us.  We tried to bring them in from ST9 and no one was successful.  So, instead I made a new file within ST10 to get some basic settings set and everyone used that instead successfully.  They then had to make the rest of their personal modifications themselves.  



Are you saying custom themes can't be copied from ST9 to ST10 and they have to be set up again?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: ST10 - Any Feedback on Installation and Use, Please

Hello Bruce,

I was just reading the comments above and some other before on forum, did clean setup, defining manually setup file locations etc.

I think that our UK Siemens friend said that it does not work because it is a new version! I am 100% sure that Siemens with more time spend on Settings and Preferences Wizard could make that happened.

I use SolidWorks Copy Settings Wizard all the time for many years between SW yearly new versions.

 

Copied my ST9 Template directory, which contains other customized files as well to ST10 Template directory, resaved\updated templates and worked with ST10 a bit.

Did save SPW, install ST10 on laptop and put just saved SPW in the laptop.

 

I have not tried to take ST9 SPW file to ST10.

 

Milan Wendl, MEngSc, P.Eng.

AAA Engineering, Canada

ST10, SolidWorks Premium 2017 SP3

 

Milan Wendl, MEngSc, P.Eng.
AAA Engineering, Canada
ST10, SolidWorks Premium 2017

Re: ST10 - Any Feedback on Installation and Use, Please

Even if you don't use SPW and just copy the appdata single user specific version 9 customization folder to the version 10 appdata customization folder it will not work? If not, because the file formats aren't compatible?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200
Solution
Solution
Accepted by topic author milanw
Friday

Re: ST10 - Any Feedback on Installation and Use, Please

@bshand  So I spoke to GTAC and found out that currently, the Settings and Preferences Wizard will not transfer from ST9 to ST10.  What we did was install ST10, then I setup the file locations for everything we needed, created a new settings and preferences file, and distributed to everyone else.  Then, if others made their own customizations, they would have to reaply those.

 

They put a request in to make it work from one version to the next so hopefully in the future this will be improved.  What I have heard of is some people (that knew what they were doing) used the registry to accomplish this.  Perhaps your suggestion of using the AppData would work as well but I have not tried it.  

 

GTAC did caution that as new features are added, removed, or modified not everything will come through perfectly.  There may not currently be any known problems with trying some of these but they are currently a "try at your own risk" deal.  I would think that the worse that would happen is you need to uninstall and reinstall if things get "broken".

Brian Fritz
Solid Edge Certified Professional
ST10 latest MP