Cancel
Showing results for 
Search instead for 
Did you mean: 

ST10 General Performance over ST9 - User Feedback

Builder
Builder

Edgers

 

Just wanted to start an honest thread to discover your early initial experience running Solid Edge St10 on windows 10 over std Microsoft network server client env with no PDM using certified hardware and drvs from Siemens listed matrix as related to your user experience running ST9.  # of clients anything from 0-15

 

Looking for things like

 

1)latency improvements

2)Graphics related issues/improvments

3)Large assembly performance

4)Assembly document open times when pushed to the screen from network

5) Geometry centric data issues/improvements

6) General UI front and backdoor experience 

7)Data Management issues/improvments/experience(non-PDM)

 

 

ST9
WIN 7Pro 64bit
DELL T5810 3.7-4Ghz 32Gb ECC
5 REPLIES

Re: ST10 General Performance over ST9 - User Feedback

Legend
Legend

Can't answer all your questions, but here's a quick list:

 

-generally snappier. Particularly the application button now works almost immediately. In ST9 you had horrible lag.

-zero graphics issues although I'm on a gaming laptop

-large assemblies much the same as ST9

-very stable. I think I've seen only 2 crashes in ST10 and I use SE extensively

 

Harri

 

Re: ST10 General Performance over ST9 - User Feedback

Phenom
Phenom

ST9 was a huge step back in performance compared to ST8, I wonder if ST10 has filled some gap.

 

Re: ST10 General Performance over ST9 - User Feedback

Legend
Legend

I started with ST9, so can't comment..

 

Hari

Re: ST10 General Performance over ST9 - User Feedback

Siemens Phenom Siemens Phenom
Siemens Phenom

FWIW, the general feedback through GTAC EMEA is that ST10 is more responsive than ST9.

Re: ST10 General Performance over ST9 - User Feedback

Builder
Builder

Dave I hope 6 sec latencies (app button) are never again something users have to tolerate......Sounds promising

ST9
WIN 7Pro 64bit
DELL T5810 3.7-4Ghz 32Gb ECC