ST6 64 bit hungs & full ram memory used

Valued Contributor
Valued Contributor

Hi Experts!

 

The GTAC couldnt help me. Maybe you had this problem before and solved succesfully.

 

Sometimes SE gets freezed with some not complicated assembilies and swallow hole RAM memory. Softwere options are set to optimium.

Till now I have tried to:

1 Clean disc C:\\ by ccleaner

2 Delete folder in C:\\...\local\temp

3 Delete files Windows disc cleaner

 

Any other ideas? Thanks a lot !

12 REPLIES

Re: ST6 64 bit hungs & full ram memory used

Honored Contributor
Honored Contributor

Hi,


what I have seen is, that this seems to have something to do with the number of documents You have opend in that Solid Edge session.

It simply could be reproduced when opening a couple of files and close them.

You will find, that SE increases the memory it uses even when nothing is opend.

Close down SE and start again will begin from low memory isage and continously will increase that.

 

Could be some memory usage effect with windows and SE

 

Can You or/and anybody else confirm that?

 

regards

Wolfgang

 



regards
Wolfgang

Re: ST6 64 bit hungs & full ram memory used

Phenom
Phenom

First off what's your Virtual Memory set to? You may need to up your Virtual Memory.

 

Typically you should have 2X the amount of Phyiscal RAM installed in your system.

 

I have 12GB so mine is set to 24GB. If you change it be sure to reboot.

 

See below to find your way there.

 

Bob

 

Virtual Memory.png

Re: ST6 64 bit hungs & full ram memory used

Esteemed Contributor
Esteemed Contributor
Hi there,

Are you running 32-bit or 64-bit Solid Edge ST6?.....and on which build of Windows? (32 / 64)
Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP2] Classic [x2 seats]
Windows 10

Re: ST6 64 bit hungs & full ram memory used

Valued Contributor
Valued Contributor

SE ST6 64 bit , Win7 pro 64 bit

 

I have set the double virtual memory as you shown and its even worse. Hungs more often.

 

Hungs especially when rotate whole asm or zoom in on detail. Sometimes hungs for a 3 seconds and run further.

 

 

 

 

Re: ST6 64 bit hungs & full ram memory used

Phenom
Phenom

Add to what Sean asked about Windows, what's the Brand/Model of your Graphics Card, and how do you have Solid Edge options set ?

 

Go into An assembly, then Click on the Solid Edge Options.

option.png

 

Then under view, tell us what you have set.

 

video card.png

Re: ST6 64 bit hungs & full ram memory used

Community Manager Community Manager
Community Manager

If when you say "hang" you mean you have to wait a few seconds after a zoom or such, then as @BobMileti says, check the graphics option and turn OFF AutoSharpen. When it is on, it has to recompute triangles to give you very fine display. If performnace is more important (and it usually is in large ASM) turn off AutoSharpen.

Dan Staples
Director, Solid Edge Product Development

Re: ST6 64 bit hungs & full ram memory used

Community Manager Community Manager
Community Manager

How much physical RAM do you have? If its 8 GB then it looks like that is your problem. Your SE model is taking up 7.2GB and the OS will take the rest.

 

Are you familiar with using Active/Inactive parts? This is how you can keep from using so much memory -- use Inactive for most of your parts.

Dan Staples
Director, Solid Edge Product Development

Re: ST6 64 bit hungs & full ram memory used

Valued Contributor
Valued Contributor

Dear Sir!

 

Thank you for view options explanations. Ram is 8gb, hungs like SE is trying to calculate smth espacially if you will add some new part in top asm...Like bus transfer is choking  and believe me its not matter of software's options because its small asm, ~500 quite simple parts only. Tomorrow I will try with all view sets to minimum and I will let you know. I just would like to know everything about how to avoid unnecessary issues. Any other more admin solution proposals?

 

Other hand, the whole data is on the server. This server has max transfer 1GB/s only. Sometimes transfer is choked in rush hours! Nevertheless almost always SE works well for us, truly more than 95% of working time. Teamcenter is another story...I think you know what I mean if you are even an user!

 

Solid Edge is sometimes unpredicted...you should know that either. Yesterday everything was works well w/o any problem. Today my blood is boiling. Same with relations!! Sometimes change or block one constrain and whole model will fly like a F16 or sub asm relations...sometimes is better to delete all relations and starts from the begenning.

 

Thanks.

 

 

Re: ST6 64 bit hungs & full ram memory used

Genius
Genius

Hello, regarding memory usage is hard for me to comment but I had such problems in the past, and the reason for this was turn off page file by my IT department Smiley Happy.

However hungs - for me the reason was anti-virus software, try to turn it off. I had installed versions of 32bit, after installing the 64bit version the problem disappeared.

SE ST9 + TC 10.1.7