ST8 Zoom in draft acting weird

Hello,

 

I recently updated to ST8 and I like the performance so far. The only thing i don't like is the slow opening and transition time (e.g. from draft to model or to another draft). In the Draft environment i came across some strange behavior. My draft acts weird when i zoom in or out (i.e. my drawing view disappears for a second). See attached picture. The problem gets worse when the assembly is bigger. Any suggestions where to search for an answer? Is it related to SE properties configuration or graphics card or something else?

 

Picture (sorry for bad quality; those lines are balloons);

st8.jpg

 

Thanks in advance,

Marko

7 REPLIES

Re: ST8 Zoom in draft acting weird

Esteemed Contributor
Esteemed Contributor

What Operating System (Win 7, 8, 8.1, 10)?

What graphics processor (embedded, geforce, quadro, radeon, fireGL)?

How much memory?


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP3

Re: ST8 Zoom in draft acting weird

Phenom
Phenom

Hi,

 

It depends on your graphics card... Smiley Wink

 

If you add these registry keys to your registry it will be useful for you!

 

HKEY_CURRENT_USER\Software\Unigraphics Solutions\Solid Edge\Version 10X\DEBUG

"DisplayInterruption"=dword:000000c8 (200)
"DisplayLightWeight"=dword:00000220 (544)

 

Try it!

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: ST8 Zoom in draft acting weird

Esteemed Contributor
Esteemed Contributor

@Imics, what do those do exactly? Are they only useful for diagnostics?

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: ST8 Zoom in draft acting weird

Phenom
Phenom

My Friend,

 

This is a fine-tuning... Smiley Very Happy Ohh no, I use these settings for daily work!

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: ST8 Zoom in draft acting weird

Esteemed Contributor
Esteemed Contributor

So, my friend, what do they do????

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: ST8 Zoom in draft acting weird

Phenom
Phenom

Hi,

 

DisplayLightWeight
The default value for this is 50, which is 50milliseconds.  If the time interval between scroll/zoom messages is less time than this value, then we enter Light Weight mode.  In this mode we will not draw hatch/fill, dimensions, or textboxes.  Blocks and groups will be represented by rectangles.  This is the main cause of what appears to be the 'stuttering' display.  If you increase this to a large number, like 1000, then the behavior will be more like previous releases.

 

DisplayInterruption
The default value for this is 200, which is 200ms.  This system stops display of remaining elements on a sheet elements if it takes longer than 200 ms to display an entire sheet before the next view scale change message arrives.  Again, increase this to a large number to simulate previous display behavior.

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: ST8 Zoom in draft acting weird

Hello and many thanks to all. The solution proposed by lmics worked like a charm. I put both values to 200 (high values slow down zooming if that makes any sense). A bit of fine tuning is required but I am wery glad I found a solution.

To answer Grundeys question. I am using Windows 7 Professional x64; Intel i5 760 2,8GHz with 8 GB of RAM and QUADRO 600 graphics card. Sorry for late response, I was out of town.

If any of you have similar performance tweaks please message me the links or explain in thread, I would be wery thankful. 

 

Regards,

Marko