Reply

ST8 wont appear as default program

When navigating my Window's File Explorer I cant open a STEP file with Solid Edge. The only thing SE related is the viewer. And when I try and find SE using the browser I cant select it.

 

I use to be able to open STEP files from the File Explorer with ST7, but it would always open another instacnce of SE. If possible I would like to be able to open STEP's from the File Explorer into my current instance of ST8.

 

Thanks,

SW 

5 REPLIES

Re: ST8 wont appear as default program

This is covered in GTAC Solution Center article 002-7004559:

 

http://solutions.industrysoftware.automation.siemens.com/view.php?si=002-7004559

 

The registry file to accomplish this can be downloaded from my personal GitHub site:

 

https://raw.githubusercontent.com/uk-dave/SolidEdge/master/open_step_in_solid_edge.reg

Re: ST8 wont appear as default program

Thank you for the quick response and info. But what do with these registry keys? Or where do I insert them?

 

Thank you

Re: ST8 wont appear as default program

[ Edited ]

@uk_dave,

How does one download your .reg link? All I get is a window full of text. Copy and save it as a .reg file (if possible) then import while in regedit?

But if it's a script that doesn't seem right so I'm not sure how to use it.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: ST8 wont appear as default program

[ Edited ]

If your browser is displaying it as text, simply right click over the window with the text and select "Save As…" [Chrome] or select all the text and copy and paste it into notepad and save as to a registry file [.reg extension].  Then simply double-click on the saved .reg file to install it.

Re: ST8 wont appear as default program

[ Edited ]

@uk_dave Thanks. I was clueless (obviously). Wasn't sure you could simply save .txt as .reg and it would work. Nor did I know you could save the window like that.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200