ST9 Helix problem

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hi Edgers,

 

I have a problem making helix curve in ST9 MP1.

I define the helix by pitch and turn. When I stet the turn to whole number (1, 2, 3, ....) is seam to create corect curve.

Helix turn 1Helix turn 1

But when I change the turn value to 1.1 SE creats this wierdly shaped curve:

Helix turn 1.1Helix turn 1.1

It is same in Synch and In Order.

 

Does anyone have the same problem or is only me?

 

Thanks for help

 

Michal Mikulášek
PLM Systems Sales Representative @ HSIcom

Using CAD since May 2014
11 REPLIES

Re: ST9 Helix problem

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

I tried this on ST9 Release and am seeing the same problem when using these parameters. Please log this issue thru your defined channels. This way your information will be gathered and you will be notified of the progress on resolving the issue.

Betreff: ST9 Helix problem

Honored Contributor
Honored Contributor

Hi,


as seen a couple of weeks ago there is also a bug regarding the value of turns.

As in the example it is set to 0.5 what IMHo should be a half turn but the result is clearly more then 0.5

20161013_1650.PNG



regards
Wolfgang

Re: ST9 Helix problem

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Logged as: IR 7856469

 

Ota

Re: ST9 Helix problem

Siemens Experimenter Siemens Experimenter
Siemens Experimenter
Thank you for logging this and all your help making Solid Edge a better product. - -Tim

Re: ST9 Helix problem

Phenom
Phenom

Hi,

 

It seems, this is fixed in MP2.

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: ST9 Helix problem

Siemens Experimenter Siemens Experimenter
Siemens Experimenter
Have you tried it on MP2? Or did you get word that it was supposed to be fixed there? I don't have MP2 installed. - -Tim

Re: ST9 Helix problem

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi Edgers,

on MP2 0.5 turn works but turns  1.1, 2.1 etc. produces still wrong results.

 

Ota

Re: ST9 Helix problem

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor
Hi Ota,

thanks for taking care of this issue.

Michal
Michal Mikulášek
PLM Systems Sales Representative @ HSIcom

Using CAD since May 2014

Re: ST9 Helix problem

Honored Contributor
Honored Contributor

Hi,



I just tested the helix again with MP2 and - maybe it was the same with Mp1 or Mp0 - but until the diameter of the helix is less than 100mm ( or view more) then everything is right, but starting with diameter larger than 100 mm the endpoint goes away from the Y-axis if the numer of turns still is 0.5

 

20161019_1139.PNG20161019_1140.PNG

 

Sorry, I confused with the x,y axis

Of course the must be changed vice versa!

 

Thanks

 



regards
Wolfgang