Cancel
Showing results for 
Search instead for 
Did you mean: 

ST9 Sketches fully constrained but showing as not fully constrained!

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

I have noticed that the sketcher in ST9 is not half as good as older versions.  Several times now I have created sketches that absolutely will not become fully constrained.  For example, I have drawn a pair of inclined co-linear lines joined together and anchored at the joint.  The angle is dimensioned as well as both line lengths but one line stays blue despite it being fully dimensioned!  The only way to fully constrain this sketch is to over-constrain it by dimensioning the overall length.  Of course the sketch then promptly goes gray if I change any length dimension other than the overall length.  So that is useless.  This is just an example and I have not made any "rookie errors" like lines on top of each other, etc.  Have a look at the attached pictures to see what I mean.  This has happened now on several occasions.  Has anybody else found this behaviour?  What about in ST10?

 

Other times whole sketches will stay blue but show as fully constained when exited.  Complete rubbish right now.

 

At some stage I will apply the latest MP to see if this problem goes away and when I get time we will move to ST10.

6 REPLIES

Re: ST9 Sketches fully constrained but showing as not fully constrained!

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @chrisstandring,

 

I can't get it to fully define, UNTIL, I place a dimension out to the intersection of the two lines....so I presume there is some geometry locating the lower line there, but the upper maybe is not?

 

Maybe look at that juncture again, delete and rebuild the relations there.

 

FullyDefinedSketch.png

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP1] Classic [x3 seats]
Windows 10 - Quadro P2000

Re: ST9 Sketches fully constrained but showing as not fully constrained!

Creator
Creator

ST9 was very shaky, glitchy etc for us. The word is that it was due to it being the first release for Windows 10. ST10 has been much better, more stable.

J.Liebert
Mitsubishi Electric
ST10 MP2
Insight
Win10

Re: ST9 Sketches fully constrained but showing as not fully constrained!

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

Hi @SeanCresswell, absolutely nothing in there to cause it to not fully define.  I am doing nothing different from what I have done over the last twelve plus years.  Earlier versions of SE never played up like this!  As far as I am concerned the sketcher has become quite buggy and something is broken!  Right now I have another sketch that is giving me fits.  All I want to do is draw a line through the centre of a semicircle and make it vertical.  SE will allow the connection but not the vertical relationship - just because!!!

Re: ST9 Sketches fully constrained but showing as not fully constrained!

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

I am glad I am not the only one.  Windoze 10 - another "upgrade" that has given me much grief!  We will roll out ST10 here as soon as I get a breather!

Re: ST9 Sketches fully constrained but showing as not fully constrained!

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@chrisstandring wrote:

All I want to do is draw a line through the centre of a semicircle and make it vertical.  SE will allow the connection but not the vertical relationship - just because!!!


Hi @chrisstandring,

 

Not sure why there is an issue on this one either.......this too, I can get to work as described.

 

Just putting it out there,....is there an incomplete Windows update pending a download &/or restart on your system[s]?

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP1] Classic [x3 seats]
Windows 10 - Quadro P2000

Re: ST9 Sketches fully constrained but showing as not fully constrained!

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

There is some other geometry in the sketch - completely disconnected from the line.  I deleted some constraints on the other geometry and the sketch came right.  I then added those constraints back in.  This behaviour is completely irrational.

 

No incomplete Windows updates on my machine.  Our I.T. department here is quite **bleep** and the Windows (Win 7 Pro) installations are rock solid.