Reply

ST9 running extremely slow on new hardware

I've been running ST7 for a while now on my computer, running very well. I got a new SSD, another 32 gigs of ram and a GTX 1080 so I decided to install windows 10 professional from scratch and install ST9 (student) 

 

Even though the computer runs much faster in pretty much every other aspect, solid edge is unbearably slow. My guess is that it is using the processor graphics ? I don't know, but it's so slow I can't use it. Rotating, selecting, moving, zooming... its so bad. 

 

Im running the latest drivers for everything. 

 

Thanks for you help,

 

Carlos

4 REPLIES

Re: ST9 running extremely slow on new hardware

Conducted more experiments and turns out Solid Edge is not using my GTX 1080, the card stays pretty much inactive while I use Solid Edge, Is there a way to fix this ?

 

 

Re: ST9 running extremely slow on new hardware

Hi there @cpendas,

 

The system, for the most part, sounds perfect for CAD use......all up untill the graphics card.

Solid Edge is looking for very specific driver coding to display it's content, and while the hardware of the GTX1080 is good, the drivers don't lend themselves to this in the best way. [specific to 3D CAD & it requiring OpenGL based "cards / drivers"]

The best way forward, in my opinion, would be to upgrade to a Quadro card, that is designed [and certified] to run these sort of professional applications.

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP0] Classic [x2 seats]
Windows 10

Re: ST9 running extremely slow on new hardware

You know, even though that might be true, it's not acceptable as a solution. 

My school's pc runs on GTX 1080 and I just tested, Solidworks, NX, Inventorand Catia all run beautifully on this hardware. 

 

Solid Edge ST8 ran great on my old 660Ti 

 

There's less and less reasons to use Quadro cards now a days, unless you need the extra memory. I don't want it to run at 100% efficiency, but the fact that my graphics card is not even being used and that every other CAD software is taking advantage of the GTX points to a Solid Edge issue, IMHO. 

Re: ST9 running extremely slow on new hardware

This fixed the issue for me, for anyone who might face the same issue:

 

Solid Edge Options > View window. Look for Application display in the upper right hand corner. The default may be Automatic Selection and Graphics card driven (advanced). If this is the case uncheck Automatic selection and select Graphics card driven. There are several other options to try. Note that to see these options you need to have a part file open in Solid Edge.