STEP Import extremely slow!

Phenom
Phenom

Hi Edgers,



just seen again, taht with ST9 (and confirmed with ST8 too) the import (opening) of a Step file into SE takes extremely long.

We have seen a Step file with a size of 14 MB (not more) containing an assembly with a couple of parts take over 10-15 minutes whereelse the same step file is opened in Inventor in less than a minute.

 

Saving this Inventor file as parasolid and importing that one happens also very fast (half a minute)  in SE then.

 

Has anybody any idea about "how to speed up that process?"

 

PS.: every option which could make the import worse is turned OFF

(stitch, body chekc, boolean, etc.)

 

 



regards
Wolfgang
17 REPLIES

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

Could it be where the STEP file is located?  I know SE writes files as it translates to where the STEP file is located so if you use a read only or slow writeable device...

 

I haven't looked into this but I've not had any of our users reporting this issue but we don't do a lot of STEP imports.


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1

Re: STEP Import extremely slow!

Phenom
Phenom

Hi @Grundey

 

 

sorry to forgot this info.

 

 

No we tested it on different computers and file location was on a fast SSD drive with enough free space.

And I think there is/was no big difference to the file server network location.

 

After starting the translation process, there is a short time of "SE thinking" followed by the complete green progress bar and then SE waits, and waits and waits and nothing happens.

 

As mentioned a 14 MB step file seems not to be to big for a fast translation task, what will be done by Inventor under one minute.

 

It is hard to argument here, why to take SE.

It will be no good story to say: " Don't care to much about translation time, afterwards with Sync You will be 100 times faster!" Smiley Wink Smiley Very Happy

 

 

 



regards
Wolfgang

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

I import step files quite often and haven't noticed it being slow. In fact I just found and opened a 16.5mb step file (all actions turned on) and it took only about a minute or less.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: STEP Import extremely slow!

Phenom
Phenom

Hi @bshand

 

thanks for a positive answer, since I also thought the tarnslation normally isn't so bad.

 

But in the last time it seems to happen more often that this imnport process gets slowier and slowier.

 

I see that You also are running ST9 MP8 and Win10

This was the next idea I had regarding that issue, but again, seems not to be so.

 

Of course it is possible that it has to do with that certain file (before asking, no I can not upload it here, You know, ....) but it is astonishing that another mid range software is able to do the same job in less than a tenth of that time, where we in SE cann't do so.

 

Maybe it has to do with the new Step Translator in SE.

I should check, wether or not I can set it back to the old one.

I think there is a registry hack to do so.

 

 



regards
Wolfgang

Re: STEP Import extremely slow!

Phenom
Phenom

Hi 

 

 

I just changed back the STep import to the old translaotr and, surprise, it did the job in approx. 1 minute.

 

So, it seems that the new translator has some problems with the import and opening of Steps

 



regards
Wolfgang

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

What new translator?

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

@bshand  ST8 introduced a new STEP Translator to replace the one used previously.  Expanded protocol support for AP242.


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

@Grundey, Oh yeah, didn't think of that. How do you switch between them? I assume mine would be the later version which seems fine.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: STEP Import extremely slow!

Esteemed Contributor
Esteemed Contributor

@bshand  You need to edit the registry to switch to the old one, so disclaimer here about changing at your own risk, making your PC unusable, reinstalling applications, etc...

 

HKEY_CURRENT_USER\SOFTWARE\Unigraphics Solutions\Solid Edge\Version 109\DEBUG

 

Set "UseLegacySTEPTranslator" to "1". 


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1