Reply

Show/Hide Components in Assembly vs. Part

[ Edited ]

As far as I can remember, SE has always been this way and I am calling it broken. I am using ST8 MP9 but it's the same on prior versions.

 

So I have an imported part model with a solid body, part copies (curves), and surfaces. I place this part into an assembly and I want to hide the curves only in the assembly. So I right click on the part in the assembly path finder, Show/Hide Components, select hide curves, nothing happens. BUT if I hide surfaces the curves AND surfaces hide.

 

In the part file it works as you would expect.

 

Am I wrong in thinking how this function should work?

 

Thanks!

10 REPLIES

Re: Show/Hide All Components in Assembly vs. Part

[ Edited ]

When I first dug into turning surfaces on and off, the big AH-HA moment for me was hitting "show everything" then the desired switches became available.

 

------I love Marvin!

You make me vary angry,

I'm going to blow up the earth with my MK28 MOduLATOR, it blocks my view of Venus.

Oh Drat, Disintegrated again.

Re: Show/Hide All Components in Assembly vs. Part

I don't think you understand my issue.

 

The curves display function is broken unless they define a curve differently in the Assy vs. Part files.

 

I will post a video when I have time.

Re: Show/Hide Components in Assembly vs. Part

[ Edited ]

Am I the only one using these toggles in Assy?

Re: Show/Hide Components in Assembly vs. Part

If you believe it to be an issue with the software, have you contacted your VAR or GTAC to report it via the IR process?

Ken Grundey
Production: ST6 MP14
Testing: ST9 MP1

Re: Show/Hide Components in Assembly vs. Part

Hi Ken,

 

I always post something here first to see if it just my misunderstanding or if I should use a different approach. The reactions I see here are usually an indicator of how GTAC will set priority. At least that has been my past experience. I'm not bashing GTAC, they're great and have to prioritize. This just gives me a glimpse of my thoughts/uses vs. others.

 

-Pat

Re: Show/Hide Components in Assembly vs. Part

And you're certain that what you're seeing isn't like the edge of a surface or an intersection between a surface and another face?

ST9
Windows 7 Professional
Nvidia K2200 & Intel Xeon
"You're doing it wrong"

Re: Show/Hide Components in Assembly vs. Part

I have a few parts that commonly behave weird with trying to hide curves. Typically with a file of this type I have surfaces, curves, sketches, but I only want to show the surfaces in the upper level assembly. I've yet to find the culprit of what makes only certain files act like you descibe, sometimes the surface toggle button, toggles the curves on & off. Also the "last save" occasionally has to be "resaved" to work correctly.

"A computer makes as many mistakes in two seconds as 20 men working will in 20 years"

Re: Show/Hide Components in Assembly vs. Part

Ok so here's the brokeness...

 

The offending geometry is the imported curves that are not being toggled by the Assembly level toggles. Yet while in the Part file the Curve toggles recognize the imported curves (Part Copies) as valid.

 

If the curves are created in the Part file and not imported, the toggles work as advertised.

 

I will submit an IR about this as I believe the part file functionality is correct and should carry up to the Assy level regardless of the origin of the geometry.

 

Thank you for the feedback. It helps me to better communicate the issue for the IR.

Re: Show/Hide Components in Assembly vs. Part

Let me add that the times I've had issues the curves were also imported. They were from an .igs conversion from a CMM probe.

"A computer makes as many mistakes in two seconds as 20 men working will in 20 years"