Cancel
Showing results for 
Search instead for 
Did you mean: 

Solid Edge ST10 MP5 crasches when using ASM

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi Edgers,



just have found that ST10 MP5 is crashing when trying to use the assembly function "Mirror Components" if there is a deeper structure mirrored, that is parts in a subassmebly within a subassembly.

 

This feature has worked good since ST5.

 

I can not say, wether this is a bug of ST10 (don't think so) or from one of the last MPs (MP4 or MP5)

 

Can anyboday confirm taht.

 

PS.: it is independed of which ASM componets example (even from the training folder of ST10) You are using.

It just stops working.

 

Tested this on different machiens, on one SE disappears from screen after pressing the final OK button. without any error message or warning, on a second machine the comes up an error "SE isn't working any longer!" after which SE disapears from screen.

 

PS2.: Win10

regards
Wolfgang
19 REPLIES

Re: Solid Edge ST10 MP5 crasches when using ASM

Gears Phenom Gears Phenom
Gears Phenom
Hi,

I can confirm this, I've already logged it.

BR,
Imics
http://solidedgest.wordpress.com/

Re: Solid Edge ST10 MP5 crasches when using ASM

Valued Contributor
Valued Contributor

Hi,

 

today my task was to mirror an entire assembly. This assembly has mirrorred parts in subassemblies 2 and/or 3 level deep. I didn't experience any issue. I am truly glad because I did't have to manually assemble the mirrored assemblies.

SE ST10 MP9
Win10 1803 17134.228

Re: Solid Edge ST10 MP5 crasches when using ASM

Legend
Legend

I don't have the problem also.

 

Can you give me the name of the training assembly?

Sander
The Netherlands

Re: Solid Edge ST10 MP5 crasches when using ASM

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Imics

 

 

 

thank You so very much for confirming it.

 

I just tried it again - on the same computer as yesterday, and what shall I say, it worked fine 3 times serial.

 

But then - fortunateley SE crashed again.

 

I was able to reproduce this failure with any assembly I tried, no matter where I was saving the new mirrored components.

 

The crash appears in two way, either without any message or response, that means SE disappears from screen and that was it, or an error message appears two times before closing/crashing SE

 

20180322_1154.PNG

 

 

This crash was done using the training assembly seaabt.asm from the training folder of the current SE version

 

But - as mentioned - I was able to do it with any SM, not differene wether it is one of the SE examples or a self made, and also no difference wether it is a new or old one.

 

But strange is, that yesterday the crashes occured every time I tried to mirror components and today it worked fine for 3 times with crashing the 4th time.

And doing it on another workstation I was able to mirror my examples a couple of times without any problem.

 

So now I'm understanding also, that some of You - @Sander-NL and @CsokaZ aslo were able to used that function without any trouble while @Imics also have seen the problem.

 

Big question now is, why and what is the reason?

 

 

 

regards
Wolfgang

Re: Solid Edge ST10 MP5 crasches when using ASM

Community Manager Community Manager
Community Manager

@Imics What is the IR number, so I can make sure it is getting reviewed/scheduled?

Laura

Re: Solid Edge ST10 MP5 crasches when using ASM

Gears Phenom Gears Phenom
Gears Phenom

Hi @LauraWatson,

 

The IR number is 9045327 and Hans Legters was the contact person from EMEA GTAC. 

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: Solid Edge ST10 MP5 crasches when using ASM

Community Manager Community Manager
Community Manager

@Imics Thanks!

Dev has checked in a fix for ST10MP6, scheduled for early April.

Laura

 

Workflow:

When using Mirror in the assembly environment and choosing as action 'mirror' Solid Edge will crash. Thereby, the part itself has been created.
Steps to reproduce:
1. Open the asm
2. Mirror
3. Select the part
4. Mirror plane: Right plane
5. Action: Rotate
6. Finish
7. Select the mirror feature in the PathFinder
8. Edit definition
9. Mirror Settings step
10. Action: Rotate > Mirror
11. Finish
12. SE will termnate

Re: Solid Edge ST10 MP5 crasches when using ASM

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @LauraWatson

 

 

 

thanks for confirming and posting the upcoming fix!

 

regards
Wolfgang

Re: Solid Edge ST10 MP5 crasches when using ASM

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@hawcadwrote:

This crash was done using the training assembly seaabt.asm from the training folder of the current SE version


I mirrored that assembly (actually seasbtb.asm) several times and I can't get SE to crash.

 

Bruce Shand
ST10 MP10 - Insight - Win10 - K4200