Solid Edge ST7 is sluggish

Creator
Creator

Hello, why is the Solid Edge ST7 moving so slow? It's unworkable. I have attached the video of the st7. It only works slowly on certain pieces with many commands, this piece has 15000 part copys.

CPU usage never passed 12-20%, physical memory never passed 40%.

https://youtu.be/bjtnBew-sKg

Intel(R) Xeon(R) CPU           E5450  @ 3.00GHz (8 CPUs), ~3.0GHz

Memory: 12288MB RAM
Available OS Memory: 12286MB RAM
Page File: 5058MB used, 31225MB available

    DirectX Version: DirectX 11

 Card name: NVIDIA Quadro FX 3800

             Display Memory: 485 MB
             Dedicated Memory: 997 MB

 

11 REPLIES

Re: Solid Edge ST7 is sluggish

Esteemed Contributor
Esteemed Contributor

Hi there,

 

After watching your video....I believe this is because the component file has imported as a collection of individual surfaces, rather than a solid model.

You may be able to use the "Show Non-Stitched Edges" tool from the Surfacing tab to identify where a missing face might be, and maybe make a repair to stitch it into a solid model.

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP2] Classic [x2 seats]
Windows 10

Re: Solid Edge ST7 is sluggish

Phenom
Phenom
I would try to import it again and check the option to stich faces, in this way all the faces with an edge in common will be joined.

If all the faces are connected the result will be a solid.
If not it will be more easy to repair it and have a solid.

Re: Solid Edge ST7 is sluggish

Phenom
Phenom

Sean is probably right. Did you import this, and from what and what were the settings.

 

Bob

Re: Solid Edge ST7 is sluggish

Creator
Creator

Imported from a step file, heal and stitch checked.

The most interesting thing is that if i put the piece into an assambly the software will move better.

Question: why is the software working so slowly if i have more than enough in pc specs?

Re: Solid Edge ST7 is sluggish

Siemens Phenom Siemens Phenom
Siemens Phenom

You have the blue circle "i" symbol on each feature. This means you need to run the Optimize command. 

 

Some of the downsides of non-optimized geometry include:

 

Window display performance 

  • Slow window updates such as zoom or fit 
  • View rotations may be slow and jerky. 
  • Abnormal display problems (Missing faces) 

Modeling problems

  • Problems adding or remove material (cuts/protrusions)
  • Direct modeling failures (unable to move face)
  • Crashes or abnormal finish to a commands

Draft Drawing view creation or updates

  • Unable to create drawing, section, or detailed views
  • Crashes
  • Update view fails, hangs, or takes an abnormally long time to finish

What the Optimize command does:

 

"Increases the precision and quality of the model by simplifying B-Surface definitions, heal edges, and identifies and replaces blend like faces with a PS rolling ball blend."


From the Solid Edge Help documentation:

 

"You can use the Optimize command to increase the quality of the imported model by simplifying B-spline definitions and healing model edges. Even if the model does not contain faults, it is always good practice to run the Optimize command since it improves the precision and complexity in most imported models."

 

Please take the time to run the Optimze command and see if this helps your issue.

Re: Solid Edge ST7 is sluggish

Pioneer
Pioneer
Agree in your opinion

Re: Solid Edge ST7 is sluggish

Pioneer
Pioneer

Agree in your opinion

Re: Solid Edge ST7 is sluggish

Creator
Creator
I tried with optimize, waited for 3 hours and nothing happened because solid edge stopped working. But thanks for the info.

Re: Solid Edge ST7 is sluggish

Siemens Phenom Siemens Phenom
Siemens Phenom

This is a  big model/file.  Don't try to optimize everything all in one operation.  Try to optimize in chunks of data and save between each optimization.