Cancel
Showing results for 
Search instead for 
Did you mean: 

Solid Edge ST8 graphics card crash

Experimenter
Experimenter

Hi all, today I tried working on Solid Edge with my new laptop for the first time. However, I experienced graphics card each time I tried to edit a part with Solid Edge: My screen goes black for a second, and when it comes back I get an error messege saying that my graphics card has crashed and recovered. From that point on, my session on Solid Edge stops working, with part screen showing only white background. 
Is there any  solutiong for this? I am using AMD Radeon R7 M265 as my graphics card, with 8 GB RAM and Intel Core i7-5500U Processor.

 

Thanks in advance!

8 REPLIES

Re: Solid Edge ST8 graphics card crash

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Dival,

The AMD Radeon R7 M265 is NOT a supported graphics card. It is designed for gaming which is a very different environment to CAD. So you you will have issues with this type of graphics card.

You could try updating the graphics driver to the latest one from AMD. Once you have done that you can try changing the Solid Edge Options, View, Application display to software driven.

 

Capture.JPG

Response will be slower but useable.

Cheers,

Mark

 

Re: Solid Edge ST8 graphics card crash

Experimenter
Experimenter
I updated the driver. Sadly, now I can't even open a new part, as the
program crashes when I do so. Because I am unable to open the part
environment, it seems like I can't make the change you suggested in the
settings, since I have to open the settings from the part environment to do
so.
Any help?
If it helps in some way, this is how the program looks like when crashing:

Re: Solid Edge ST8 graphics card crash

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

I would try rolling back the driver and then try :software driven".

Good luck

Mark

Re: Solid Edge ST8 graphics card crash

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

What OS are you using?

 

SE delivers in C:\Program Files\Solid Edge ST8\Program a file called "Autoconfigure.txt".  This file comes from Siemens PLM support to automatically configure many cards.  The Radeon series has only 2 lines... one specifically for the Win 7 OS and another for all other OS's.

 

ATI | Radeon | * | WIN7 | HX | HX | DL,SL
ATI | Radeon | * | * | BS | HX | DL,SL

 

Depending on your OS you can change one of the 2 lines to Software Driven (legend below from the file), so it should look like this:

 

ATI | Radeon | * | WIN7 | SW | BS

 

// You can add, modify, or delete cards and the setting by following the format:
// Vendor | Card | Driver Version | Operating System | Default | Maximum [| Options]
// Operating Systems are
// WIN2K (Windows 2000)
// WINXP (Windows XP)
// VISTA (Windows Vista)
// WIN7  (Windows7)
//
// Default or Maximum settings are:
// HX/GA (Graphics card driven advanced)
// HW/GB (Graphics card driven basic)
// SW (Software driven)
// DX (DirectX driven)
// BS (Backing store)
//
// Options include:
// SL (Enable shaders)
// DL (Enable display lists)
// SB (Use single buffer hilite)
// MT (Use multithreaded renderer)
// FF (Use fixed-function pipeline)
//
// An * in a field will indicate a wildcard
//
// Users should not edit this file. Any graphics card related problems should be
// reported through support. This list will be delivered with each version of
// Solid Edge and version service packs



Ken

Production: ST10 MP7
Testing: SE 2019
http://Grundey.blogspot.com

Re: Solid Edge ST8 graphics card crash

Experimenter
Experimenter

I've made the change you suggested, same problem...
Here is a screen capture, in case it helps somehow:

Capture.PNG

Re: Solid Edge ST8 graphics card crash

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

If you can get to them, open your Solid Edge Options and check that the setting took.  You can override it if it did not.

2016-01-05_8-31-36.png



Ken

Production: ST10 MP7
Testing: SE 2019
http://Grundey.blogspot.com

Re: Solid Edge ST8 graphics card crash

Siemens Phenom Siemens Phenom
Siemens Phenom

Manually set the backing store using the registry.  

 

With Solid Edge closed add the following registry values (registry file attached for your convenience):

 

[HKEY_CURRENT_USER\Software\Unigraphics Solutions\Solid Edge\Version 108\PrefSets\Options-View]

"AutoConfigure"=hex:06,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

"BackingStore"=hex:02,00,00,00,00,00,00,00,02,00,00,00,00,00,00,00

 

 

 

Re: Solid Edge ST8 graphics card crash

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

Just to be clear, the code looks for 2 more lines ..begin & end... so its possible you may have left these lines out so be sure to include 3 lines at the minimum and you can make the single card line very generic...

 

BeginGraphicsCardList

* | * | * | * | SW | HW

EndGraphicsCardList

 

That way in case there is any possible difference our code is not picking up and matching it won't be an issue. Brands change minor model numbers and  NVidia has from Quadro to Quadro FX and back to Quadro which caused some issues as well... so for those that followed this thread I think the 3 lines is the minumum setting that should enable SE to open.