Showing results for 
Search instead for 
Did you mean: 

Solid Edge with Floating License & TCP Port.


Hello there. I am not sure this is correct place to ask question about license. But I have a question.


I have Solid Edge Floating License with Hardware Key. I have dedicated Server PC to host license.

I insatalled license manager on Server PC and started service using lmtools.exe. Read SELicense.dat file, started Lienese.


I understand that I have to open TCP:27000-27009 for LMGRD service. AND one of TCP:5xxxxx for SELMD service.

Otherwise my client PC can't read license.


My question is WHY SELMD service use one of TCP:5xxxxx port ? and WHY keep changing that TCP port?

When I set up license at 1st, I have to open TCP:59251 about month ago and today I have to open TCP:50643.

Here is my debug.log showing TCP port



13:56:22 (lmgrd) (@lmgrd-SLOG@) ===============================================
13:56:22 (lmgrd) (@lmgrd-SLOG@) === LMGRD ===
13:56:22 (lmgrd) (@lmgrd-SLOG@) Start-Date: Tue Nov 21 2017 13:56:22 Pacific Standard Time
13:56:22 (lmgrd) (@lmgrd-SLOG@) PID: 4796
13:56:22 (lmgrd) (@lmgrd-SLOG@) LMGRD Version: v11.14.0.1 build 188735 x64_n6 ( build 188735 (ipv6))
13:56:22 (lmgrd) (@lmgrd-SLOG@)
13:56:22 (lmgrd) (@lmgrd-SLOG@) === Network Info ===
13:56:22 (lmgrd) (@lmgrd-SLOG@) Listening port: 27001
13:56:22 (lmgrd) (@lmgrd-SLOG@)


13:56:24 (selmd) (@selmd-SLOG@) === Vendor Daemon ===
13:56:24 (selmd) (@selmd-SLOG@) Vendor daemon: selmd
13:56:24 (selmd) (@selmd-SLOG@) Start-Date: Tue Nov 21 2017 13:56:24 Pacific Standard Time
13:56:24 (selmd) (@selmd-SLOG@) PID: 15352
13:56:24 (selmd) (@selmd-SLOG@) VD Version: v11.14.0.1 build 188735 x64_n6 ( build 188735 (ipv6))
13:56:24 (selmd) (@selmd-SLOG@)
13:56:24 (selmd) (@selmd-SLOG@) === Startup/Restart Info ===
13:56:24 (selmd) (@selmd-SLOG@) Options file used: C:\SEFlex\Program\selmd.opt
13:56:24 (selmd) (@selmd-SLOG@) Is vendor daemon a CVD: No
13:56:24 (selmd) (@selmd-SLOG@) Is TS accessed: No
13:56:24 (selmd) (@selmd-SLOG@) TS accessed for feature load: -NA-
13:56:24 (selmd) (@selmd-SLOG@) Number of VD restarts since LS startup: 0
13:56:24 (selmd) (@selmd-SLOG@)
13:56:24 (selmd) (@selmd-SLOG@) === Network Info ===
13:56:24 (selmd) (@selmd-SLOG@) Listening port: 50643
13:56:24 (selmd) (@selmd-SLOG@) Daemon select timeout (in seconds): 1
13:56:24 (selmd) (@selmd-SLOG@)



Re: Solid Edge with Floating License & TCP Port.


Having had a look at what you post, I have a question for you: I assume both license server and workstation are within the same LAN, both behind a firewall.
In that case, opening ports would not be an issue within the local (trusted) LAN.

If you install both the license server and SE as vanilla as they come within the download package, it should run without trouble.
You should make sure both license server and workstation have the same license file.

As far as I know, the license server would run just fine as long as you change the server name in the license file you receive from GTAC.
The standard mentioned port of 27001 will work…
So you having to change / open more port numbers sound a bit strange…

Just to give you an impression, we run floating license running a license server reachable from both inside (LAN) and outside (WAN) using a FQDN for the server name and having only the ports 27001 & 27002 open (and forwarded from WAN to LAN side).
Runs super and does not force us to borrow licenses (which users once in a while forget to do….)

So overall, there is something strange in your build / network settings.


Marc Boom /

Re: Solid Edge with Floating License & TCP Port.


Hi Marc. Thank you for your response.

Let me change the question.

What does SELMD.EXE do? Debug.log clearly shows that SELMD is Listening port: 50643...

If I don't open that port, Client PC can't read license.

Re: Solid Edge with Floating License & TCP Port.

Esteemed Contributor
Esteemed Contributor

Hi @masakikura




but as @marcboom already mentioned, as long ass the two PCs are in the same LAN, tehre is no need for opening ports.

I also remember taht I have seen many years ago, what You claim, FlexLM is using changing ports.


But if a Fierewall is regarded, so I do not define a prot number for allowing access but the two executables from server.


lmgrd.exe and selmd.exe


This always helps and gives accees to the license server




Re: Solid Edge with Floating License & TCP Port.

Siemens Genius Siemens Genius
Siemens Genius

you have to define port Vendor, otherwise it will be used randomly choosen port. 

Add this to you SE license file:

VENDOR selmd Port=27002.

If you are using FlexnNet Publisher, you can define this port direcntly:

2017-11-22 10_34_12-atlnzt034srv.png

Re: Solid Edge with Floating License & TCP Port.

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

you have to allow incoming connection in Windows FW for LMGRD.EXE and SELMD.EXE.

that's all.

Eventually open ports 27001-27009, but only if still not working.


Re: Solid Edge with Floating License & TCP Port.


Hi Tom.


It seems your suggestion worked just fine. Thank you very much.


Debug.log shows


 7:46:26 (lmgrd) Started selmd (pid 9932)
 7:46:27 (selmd) FlexNet Licensing version v11.14.0.1 build 188735 x64_n6
 7:46:27 (selmd) SLOG: Summary LOG statistics is enabled.
 7:46:27 (selmd) SLOG: FNPLS-INTERNAL-CKPT1
 7:46:28 (selmd) SLOG: VM Status: 0
 7:46:28 (selmd) Using options file: "C:\SEFlex\Program\selmd.opt"
 7:46:28 (selmd) Server started on SMICAServer for:    solidedgeclassic
 7:46:28 (selmd) server_id    
 7:46:28 (selmd) EXTERNAL FILTERS are OFF
 7:46:28 (selmd) Not logging UNSUPPORTED messages
 7:46:28 (lmgrd) selmd using TCP-port 27002