Cancel
Showing results for 
Search instead for 
Did you mean: 

Some part/subassembly is missing in Main Assembly.

Solution Partner Builder Solution Partner Builder
Solution Partner Builder

Hi All,

 

Have you face experience where you have a assembly file which contain few parts and subassembly.

 

Then this assembly then being insert into a main assembly, but there is problem when some of the parts/subassembly not show in main assembly.

It only will show when I click edit in place for the subassembly. I try to click save and Update component also the same.

 

Refer the picture. The picture is in Edit in Place mode so you can the the subassembly. But if I exit the highlight subassembly will dissapear.

2 REPLIES

Re: Some part/subassembly is missing in Main Assembly.

Gears Phenom Gears Phenom
Gears Phenom

@Arisy

 

is it possible that this is imported geometry?   Its possible that these are surface bodies and not design bodies.

 

IF this is so,  you can toggle from construction to design at the part level (prefered method) ... and/ or show surfaces at the assy level.

 

However,  I too have seen instances where it just seems like something will not display the way one would expect.  in such cases, active those parts and run the update all on the assy to see if that helps.

 

 

 

 

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX11 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.7

Re: Some part/subassembly is missing in Main Assembly.

Solution Partner Builder Solution Partner Builder
Solution Partner Builder
Hi,

Thanks for the suggestion. Actually all the steps you mention is quite helpful. But after all the trial at last I found the solution due to the occurrence properties setting. Don't know why by default it hide the part in subassembly. Anyhow thanks for the great helps!!