Swept Protrusion

Valued Contributor
Valued Contributor

I am seeing issues with swept protrusions that I cannot apply axial relationships to the part that has a circle swept over the profile shape. I have to use the sketch of the sweep and apply the mate to it. Have I missed something?

 

Thanks G

4 REPLIES

Re: Swept Protrusion

MLombard
Retired

In order for Solid Edge to make geometry that you can make relations to, you have to be careful about how the sweep is put together. I just yesterday made a couple of sweeps that I was able to make mate relations to in assembly. I know it works, but to create a situation where it won't work would mean that SE is approximating something with a spline. It might happen because of a twist induced or non-prismatic shapes or a transition between section shapes or one of a hundred other situations. Would it be possible for you to post a part file?

Retired Community Manager for Solid Edge. This account is no longer active.

Re: Swept Protrusion

Valued Contributor
Valued Contributor

I've attached the part that is giving me grief Smiley Happy

 

As you can see it is a very simple swept protrusion.

 

Thanks

 

G

Re: Swept Protrusion

Valued Contributor
Valued Contributor

As soon as I posted it I knew what was wrong! Smiley Happy

 

I had the wrong setting in the dialogue box. It should be set to no merge.

 

Sorry about that and thanks for your time.

 

G

Re: Swept Protrusion

change face merge to "no merge" and note that you will then get tangent lines on your part..  then you will be good to go in assembly.

 

2015-06-03_1127.png