Cancel
Showing results for 
Search instead for 
Did you mean: 

TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Pioneer
Pioneer

In Assembly, sometimes I open subassembly and try to select a part to delete it but as soon as i select the part, it creates a copy of it and puts it in assembly. It does not happens everytime but many times. Can anyone help?

6 REPLIES

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi there,

 

I wonder if Inter-part links could cause this.....do you have/use these?

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge ST10 [MP8] Classic [x3 seats]
Windows 10 - Quadro P2000
Testing: Solid Edge 2019

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Pioneer
Pioneer

I guess you are reffereing to interpart relationship. I have not used any special command like interpart link. Its just simple assembly of subassembies using command assemble. 

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Phenom
Phenom

If I'm correct, I also see this behaviour occasionally.

My interpretation of the the problem is - in an assembly, selecting a part/assembly in pathfinder adds a new instance of the part/assembly, instead of just highlighting it (as if you grabbed it in pathfinder and dragged it into the modelling window, or doble-clicked on it)

 

I don't think it has anything to do with part copies.

I've mostly seen it on big assemblies, and it's almost like the single click on pathfinder is being iterpreted as a double-click.

 

Is it happening in large assemblies?

HP Z420 16GB RAM
Quadro K4000
ST10 MP6 on Windows 10 Pro 64.

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Pioneer
Pioneer

yes it happens in big assemblies. 

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Phenom
Phenom
Its some kind of delay, or something similar where a single click is being recognised as a double-click.
I notice it only happens on certain files but I'm not sure of the exact cause - whether workstation limitations or delays due to network.
It doesn't happen as often now that we have decent workstations.
HP Z420 16GB RAM
Quadro K4000
ST10 MP6 on Windows 10 Pro 64.

Re: TRY TO DELETE BUT CREATES COPY PART IN ASSEMBLY

Legend
Legend

I notice it sometimes also. I thought it had something to do with the Space Navigator I use.

Using SE since V12, 2002
ST10 certified