Unit of Measure in Teamcenter Viewer and Solid Edge generated .Jt files

Experimenter
Experimenter
We recently solved an issue that I thought would be helpful to share with others. We are using Teamcenter 10.1.6 and Solid Edge ST9. Teamcenter comes with a basic visualization package that allows you to view a 3d image of any part or sheet metal item created with Solid Edge. When you use the viewer in Teamcenter It has a handy measure tool that can be used to get dimensions of the item you are viewing. This is great because anyone can get needed measurements with using a cad program. The problem we have is the dimensions were being returned in meters and we are using feet and inches. You can convert meters to inches but it’s a pain and when you are measuring something small like the gauge of a sheet metal part you get a thickness of 0.00 M which is not a lot of help. There is no option to change the units in the viewer because the units are stored in each individual .JT file. When you do a Save as Translated in Solid Edge and you pick JT as the file type you can choose the units in the options. However the setting here has no effect on the jt files that are auto generated when you check an item into Teamcenter. Thru GTAC we discovered the settings are stored in the SEECtoJT.ini. This file is located in the Program files\Solid Edge ST9\Program folder on your computer. To change the units open this file with a text editor and look for the line that says JT Units=m and change the m to in if you want inches. Valid choices are: Millimeters – mm; Centimeters – cm; Meters – m; Kilometers – km; Inches – in; Feet – ft; Yards – yd; Miles – mi
1 REPLY

Re: Unit of Measure in Teamcenter Viewer and Solid Edge generated .Jt files

Creator
Creator

Interestingly for us, changing "JT Units" to "in" works for parts in the TC 's JT viewer, but trying to take a measurement for an assembly using the JT viewer in Structure Manager still give a measure in meters. Is it an issue you have also solved?

 

Thanks,