Using Family of Parts in Alternate Assemblies + Searching for Alternate Assemblies in Insight

Creator
Creator

This is a multipart issue/question: Smiley Frustrated

 

1) I am trying to use a "Family of Parts" part in an assembly's "Alternate Assemblies". Everytime I setup the family of part difference between the assemblies, save, and close the file, it resets to the original part for all configurations. Is there a way to fix this?

 

2) I am also setting up different file properties for the alternate assemblie but these don't seem to be searchable in Insight using  Solid Edge Search. Is there anyway to find the part number of an alternate assembly in a search?

 

 edit: To clarify, I am not using the master part in the assembly. I am using a different populated members for each alternate assembly.

 

 

4 REPLIES

Re: Using Family of Parts in Alternate Assemblies + Searching for Alternate Assemblies in Insight

Creator
Creator

Okay I figured out my first question.

I defined "Alternate Components"  for the part and selected all the "Family of Parts" components. For some reason this allowed the alternate parts to be remembered when switched between assemblies. The pop-up menus for both switches look identical with variances in the titles of the boxes.

 

Can I enter a problem report for this issue? Honestly I shouldn't need to go through this step for using different family of parts members within configurations of alternate assemblies.

Re: Using Family of Parts in Alternate Assemblies + Searching for Alternate Assemblies in Insight

Creator
Creator

Another issue has popped up now. When I choose all 17 of my "family of parts" parts using the "alternate component" method it seems to loose 1 of them every single time. All 17 options are in the same location and the other 16 are correct. 2 of my alternate assemblies use this part, but upon not having it listed in the alternates, they reset to another part.

 

Also when I go to redefine the part the other 16 show up as cache locations.

Re: Using Family of Parts in Alternate Assemblies + Searching for Alternate Assemblies in Insight

Esteemed Contributor
Esteemed Contributor

I can't address your other issues but I think the cache locations are normal in a managed environment.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: Using Family of Parts in Alternate Assemblies + Searching for Alternate Assemblies in Insight

Creator
Creator

The "Family of Assembly" updating was a PR that was addressed in ST8 MP3

 

https://community.plm.automation.siemens.com/t5/Solid-Edge-Forum/Solid-Edge-ST8-Maintenance-Pack-3-A...

 

It appears that the updates to configurations was not uploading in Insight which is why it reset the part when reopening the file. I was able to correct this manually by manually uploading and checking-in the assembly.