assembly patterning error (what am I doing wrong?)

Creator
Creator

I can't seem to get this pattern to take, it looks like it's going to work, and then it gives me a strange error that I don't understand, and it shows the pattern in the tree, but it's got a red squiggle.

 

a video that shows the problem better than I can explain it

 

what am I doing wrong here?  It seems like it reconizes the hole patter, but doesn't want to place the parts.

 

3 REPLIES

Re: assembly patterning error (what am I doing wrong?)

i've seen this error before as well but never really understood it.

 

Try to make sure you are using the same occurance for both patterns if the are duplicating a pattern on the same features set.   better yet,  just edit the st pattern to add the new instance to be patterened...

 

I dont think this is what you have goign on per the video...

 

hopefully someone else can shed some light here.

Re: assembly patterning error (what am I doing wrong?)

Phenom
Phenom

I don't want to hijack the thread, but creating an array never appears to be a simple task.

 

How does one make a circular pattern of objects with no reference pattern? I just want to pick the object, locate the center, then tell the command the number of objects in X degrees.

 

I'm an old AutoCAD guy, just like the Array command in AutoCAD. All of the stuff in SE wants a 2D reference pattern.

 

Is a 2D pattern or feartures a necessary step for SE to pattern parts?

Re: assembly patterning error (what am I doing wrong?)

YES,  you need a pattern sketch or part based pattern to pattern in assembly...

 

there are new pattern-like features such as duplicate componant which are very powerful as well