can not rotate design body if i have pattern in features

Pioneer
Pioneer

(view in My Videos)

 

Hello,

I updated my solid edge from ST5 TO ST6 and now I can not rotate part if it has pattern in features.
1. create a part and drill a hole
2. create pattern with that hole
3. right click on part and select design body
4. click on wheel to rotate........gives error

I have to break pattern every time to manipulate that part. is there any shortcut for it?

5 REPLIES

Re: can not rotate design body if i have pattern in features

Esteemed Contributor
Esteemed Contributor
Hi there,

Could you upload a screen recording of what you're seeing/attempting?
Something about wanting to "Rotate" a hole feature doesn't seem right...and therefore struggling to reproduce your error.
Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP2] Classic [x2 seats]
Windows 10

based on a quick look a tthe video...  I believe this is...

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Grundey:  Based on further back and forth between the discussions MJOHNSON stated that it appears to be a problem with the software and is being logged as such.  Accepting this as the answer.

 

 

based on a quick look a tthe video...  I believe this is a  live rules viloations... not so much the pattern being the root cause.

 

You can test by simply supressing live rules and then doing the rotate.

 

I'd suspect orthogonal to base might be one rule to look at...? (have not played with a test case)

Matt Johnson
Application Engineer
Ally PLM Solutions
matt.johnson@allyplm.com
http://allyplm.com/

Re: based on a quick look a tthe video...  I believe this is...

Pioneer
Pioneer
Matt, thank you for your answer. As you see in video, I already clicked on suspend live rule button.
also some times it allows me to rotate till 90 degree angle but if i put 180 degree then it gives me error. I think this is a strange behavior of software.

Re: based on a quick look a tthe video...  I believe this is...

Solution Partner Legend Solution Partner Legend
Solution Partner Legend
"Mano",

I created a test case like you showed and in ST6 I can confirm the behavior you are seeing. Please submit and IR with your VAR or GTAC.
Matt Johnson
Application Engineer
Ally PLM Solutions
matt.johnson@allyplm.com
http://allyplm.com/

Re: based on a quick look a tthe video...  I believe this is...

Pioneer
Pioneer
I submitted IR with GTAC.