editing blocks

Valued Contributor
Valued Contributor

I have a draft that I want to insert as a block into another draft in such a way that the 0,0 point on both drafts line up.

Dragging the draft in from the library, I see that my block is up and to the right of where I wanted it to be, and SE has chosen a handle point even with the leftmost and bottom-most geometry within that block. (Some point out in space.) This handle point appears at 0,0 on the draft document.

When I right click on the new block and select "properties", I can verify that the insertion point (labeled "Origin point") is 0,0.

 

So, my question is how do I set that origin point, within the block, so that all of my blocks can have an insertion point of 0,0 on my draft and be perfectly superimposed?

 

When I create a block out of geometry on the same draft instead of inserting a draft as a block, I can pick an origin point during the process. When I insert a draft as a block, I can't. (On a side note, Why does dragging seem to be the only way to create a block from a draft? No menu item, ribbon button, or shortcut menu item? I have to be psychic, I guess? This should be a shortcut, not the only method.)

 

Am I going about this the wrong way? Did something change? I know I've done this before and I could swear it worked for me in such a way that I could ensure that the positioning could be trusted.

 

Untitled.jpg

 

3 REPLIES

Re: editing blocks

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

It is all about where you define your block origin.

This short video should make it clear.

(view in My Videos)

 

Cheers & Happy New Year

Mark

Re: editing blocks

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Another thing is that you have a great deal of flexability in selecting your alignment point on your target block or geometry.

In the first part of this video I do not touch on any part of the existing geometry - hence no alignemnt points. In the second part you can see how I easily select several different alignment points.

(view in My Videos)

 

Cheers

Mark

Re: editing blocks

Valued Contributor
Valued Contributor

I can't see that second video for some reason. Thank you for the first video, it's helpful. What I really want is to just drop a .dft, one which as no blocks defined in it, as a block into another draft. I see it as a problem that Solid Edge doesn't let me define an origin, or even just use 0,0 point. I want the 0,0 point of the draft which is now a block to be perfectly superimposed with the 0,0 point of the draft I am inserting into. I don't really want to open the other draft and create a block. Especially useful and seemingly absent is the ability to change the origin point of a block after the fact of its creation, no matter which method is used to create the block (insertion or create from local geometry).

 

It turns out what I was attempting to do, or rather help a co-worker to do, was create what we used to call in autocad an External Reference. I previously thought Solid Edge was unable to do this in quite the way we wanted. Perhaps someone can elaborate when this functionality was added?

 

When I started this thread initially, I was operating on the assumption that I needed to bring in the other draft as a block as I described above, which is somewhat incorrect, I guess.

 

The solution, at least for me, is that one needs to click in the white space of the library (while "Show blocks" is un-selected) and select "Insert Symbol As" option "Link". Then I could drag the draft in (as a "linked symbol", to use SE terminology) and change the insertion point to 0,0 under properties and the draft was superimposed perfectly as I desired. (Strange that the two types of "symbol" insertion methods automatically choose two different handle points.)

 

Changes made to the other draft are reflected and displayed by the draft which contains the other as a link. Bonus.

 

This has been a desirable functionality for me for a while. It was so hard to figure out how to do this, for all I know this has been available for a few versions now. This method of clicking in the whitespace to set the workflow options for a process that one hasn't even initiated yet is ludicrous. A better way would be to ask what type of symbol after the user drags the symbol in and begins the process. I had to really look in help to find that, and I never would have found it on my own. Then add to that the fact that the options are greyed out for some reason, if you have the "show blocks" option selected.