how to make SE not put item count when placing a parts list

I have a few issues with the parts list command.

 

1. When I insert a parts list in a draft, the default list is always ansi, I want it to be my custom list.

 

2. The parts list bubbles always come in with the item count, I do not use the item count, this may be related to this problem, but in my parts list propertys box the balloon tab is "greyed out".

 

3. The parts list always comes in with an exploded list, I want it to default to top level, however once again the list control tab under the propertyies box is greyed out.

 

I can and have been working around these issues for several releases and think it is about time to address them

 

John

5 REPLIES

Hello John,   The Solid Edge Parts List command is very p...

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello John,

 

The Solid Edge Parts List command is very powerful but takes a little patience to get used to it.

To answer your questions:-

 

1. The order of the saved settings is alphabetical - hence ANSI tends to be on top. For your custom setting to become the default simply call it "AAmysetting" or similar. By the way these setting are saved to ..\Solid Edge ST6\Template\Reports\DraftList.txt - you can edit them directly if required.

 

2. Those options which are "greyed out" are in this state because it is not possible to change them once the list is populated. This is another area that takes a little getting used to. To access any of the options you must do so BEFORE placing the parts list. The work flow is as follows:-

  a)  Select Parts List command

  b)  Click on the Drawing View (this is what it is telling you to do in the Prompt Bar)

  c)  Now you can either edit the properties of the parts list (including balloons) or click to place the parts list - this is also in the prompt bar.

 

3. Edit the List Control Tab before placing - see above.

 

I have been using and training Solid Edge for more years than I care to remember and I am still amazed at what I discover when I read the Prompt Bar.

 

Cheers

Mark

 

Re: Hello John,   The Solid Edge Parts List command is very p...

Valued Contributor
Valued Contributor
John,

Wrong. One of the IMPROVEMENTS of the ST6 is that it does not remember the last selection of the parts list settings and it gives you ANSI if you do not select every time the setting you want. For many years my settings are called AAA, related to my company name . When I 'look' at the pull down list AAA is still highlighted but it is not used. No matter what the next ANSI is always used. To get away from this insanity, I had to kick the ANSI out and copy my AAA in draflist.txt to BEGINSET CONFIGNAME=ANS to get the parts list and the balloons the way I want them.
Check it John.
Milan Wendl, MEngSc, P.Eng.
AAA Engineering, Canada
ST10, SolidWorks Premium 2017

Re: Hello John, The Solid Edge Parts List command is very p...

Thanks milanw, you fixed it.

Re: Hello John, The Solid Edge Parts List command is very p...

Esteemed Contributor
Esteemed Contributor

I've never seen the list control tab greyed out after placing a parts list.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: Hello John, The Solid Edge Parts List command is very p...

Hi @MF

 

I see your response of a post last few years.

 

I thought perhaps I face same situation just like the post you responded. Could you spend few minutes help me? I see my problem have some connectivity with the problem

 

Here the link to my post.

https://community.plm.automation.siemens.com/t5/Solid-Edge-2D-Drafting-Forum/Alphabet-Item-Number-in...

 

Thanks