Showing results for 
Search instead for 
Did you mean: 

"Error in sectioning the view" - Help please!


Hi all, Laurence here, first time poster.


I was working on the draft of an assembly, after working on the assembly I went back to the draft and updated a section view only to have it produce an error.


This is the draft before updating, the section view is at the bottem:




And this is the draft after a (quite lengthy) Update Views:




The sectioning has dissappeared, creating new section views grants the same error after this point.

In fact, after this error appeared the first time I can't do ANY model changes to ANY files, this includes extrusions, cuts, PMI Section views, draft section views, etc... I can only create round and chamfers!

This is a screen of me creating an extrude in a new part:



After I restart Solid Edge the bug is fixed, untill I update the first draft again...

Does anyone have any idea what might be going on here? Any help is greatly appreciated!



-Laurence Van Geyte






Re: "Error in sectioning the view" - Help please!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Welcome Laurence,


First thing this section "2D Drafting" is for users of the free 2D Solid Edge Product - you will most likely get a better response if you post to the "Solid Edge Forum". It is a little confusing.


I have been using and supporting Solid Edge for more than 15 years and I have not seen anything quite like this. If you can answer a couple of questions it may help others as well: What version and maintenance pack of Solid Edge are you using, what operating system are you using, where are your files kept - local or on a server?


My gut feeling is that this is not Solid Edge causing the issue but something in your operating system environment. The symptoms you describe are very similar to those I have seen when the Windows Registry became corrupt. This is most unusual these days but maybe not unheard of.


What I would suggest is that if you can log on to your PC as a different user who has not run Solid Edge and then try the operation again.  different user will have a different (fresh) registry hive which should be free of errors. If this does make a significant improvement then it might be worth recreating your normal Solid Edge registry hive.


Good luck


Re: "Error in sectioning the view" - Help please!




Thank you for the reply, yes I see that now, I'll repost this question in the other forum after this.


My Solid Edge version is x64, my OS is windows 7.

The draft file with hich this keeps happening is located in a shared server location.

My colleague has attemted to open this draft on his workstation, same specs, and has recieved the exact same error.

Therefore the problem seems to be located with the file itself, as if it has gone corrupt, is this possible?

Re: "Error in sectioning the view" - Help please!


Thread has been reposted to:


This thread can be locked if necessary, cheers,