Reply
Solved! Go to solution

"Replace Part" error. SE says they have the same name.

[ Edited ]

I got this message when attempting to replace a part. The part I am replacing with was created by using "Replace Part with Copy". I changed the file name, stored it in the same folder as the original part and the assembly. The part was created in the folder with the new name, but not placed in assembly, because I got this message. Now whenever I try to "Replace part" and select the new part, I get the same message. The parts DO in fact have different names, and everything is in the same folder.

 

6 REPLIES

Re: "Replace Part" error. SE says they have the same name.

This may be related to this error, which is also nonsense because there is only one part with that name anywhere and it is in the same folder as the assembly. In other words, placing a part from folder A into an assembly from folder A yields this message.

 

Re: "Replace Part" error. SE says they have the same name.

What are the actual filenames? 

 

Can you repeat this workflow if you start a new assembly in a folder somewhere else and add dummy part documents with the same names?

-Dylan Gondyke
Solution
Solution
Accepted by topic author DGMCENGINEERING
‎08-26-2015 04:32 AM

Re: "Replace Part" error. SE says they have the same name.

Have you tried to fix this with "Revision Manager".....or possibly "Edit Links", although, the later has a UI in need of a serious overhaul, not saying RM is a whole lot better.

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST9 [MP8] Classic [x2 seats]
Windows 10

Re: "Replace Part" error. SE says they have the same name.

After examining the actual paths for these parts using occurence properties, I think the problem is due to the fact that our file server has had some workaround installed because they replaced a server and were unable to give it the same name and so now instead they redirect us now automatically. Honestly I don't remember details, you'd have to ask our Information Technology  Dept. But the fact is that now some of our older files do seem to have a different path (if you ask SE, anyway) than our new ones, even though it all looks the same to me.

I'm going to mark this one down as SOLVED and blame our IT department, like I do every day. That being said, I think there may be a way that SE could be fixed to have it ask the OS for the file path instead of using the location it remembers.

Re: "Replace Part" error. SE says they have the same name.

Good idea on the revision manager, I know because it crossed my mind as well (and good ideas are all I ever have).

 

Thanks guys, for looking into this for me.

Re: "Replace Part" error. SE says they have the same name.

[ Edited ]

DGMCENGINEERING wrote:

Good idea on the revision manager, I know because it crossed my mind as well (and good ideas are all I ever have).

 

Thanks guys, for looking into this for me.


 

All good.....I'm struck with that same disposition, although, others may suggest I'm full of other matter than good ideas.  Robot LOL

 

I moonlight as our IT dept as well......a little jealous, I'd really like if it was someone else that gets the blame. Robot wink

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST9 [MP8] Classic [x2 seats]
Windows 10