Cancel
Showing results for 
Search instead for 
Did you mean: 

selecting dimensions when creating relations

Phenom
Phenom

When I'm creating relations, more noticably in the mate or planar, and have selected the first part the dimensions for other relations show up and are selectable along with planar faces. 

Does anyone know why a dimension would ever be a desirable input when selecting part elements to place a relation on? 

Is there a way to turn that off? 


->If you cannot find a Solid Edge setting, confirm you have a file open of the type that will be affected.
->If you have started a thread and a response solves the problem or answers the question you asked, then please mark it as solution. Note, there can be multiple solutions for a thread.
3 REPLIES 3

Re: selecting dimensions when creating relations

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@bnemec,

 

I thought that was something NEW......I see this also.

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP8] Classic [x3 Seats - Cloud Enabled]
Windows 10 - Quadro P2000

Re: selecting dimensions when creating relations

Siemens Phenom Siemens Phenom
Siemens Phenom

The reason you can select the dimension is so that you can edit the associated relationship. It's sort of a shortcut so you don't have to go look through the dropdown list on the command bar. You can turn off this behavior by clearing the 'Show all dimensions' setting on the Assemble Options dialog:

 

 assembleoptions.png

 

Hope this helps,

Greg

Re: selecting dimensions when creating relations

Phenom
Phenom
Thanks Greg, that does help a little. What you are saying is desired behavior and I find that feature handy when evaluating the assembly. I do not find that feature handy while in the place relation command. My brain does not find it logical to want to edit one dimension while trying to select an element in the relation command.

Sometimes the dimensions get in the way, using a 3D input device and sluggish graphics I wind up clicking a dim instead of the element I want. Then I'm in an unknown state, am I still in the place relation command? am I editing a dimension?

->If you cannot find a Solid Edge setting, confirm you have a file open of the type that will be affected.
->If you have started a thread and a response solves the problem or answers the question you asked, then please mark it as solution. Note, there can be multiple solutions for a thread.