Reply

Re: ST9 performance is worst than ST8!


KeithCain wrote:


Hello Fiorini,

 

I have looked into this and logged it as an issue.

 

Thanks,

Keith

 


Thanks Keith !

Re: ST9 performance is worst than ST8!

@LauraWatson, @KeithCain

>we were able to identify a couple of performance fixes. 

Could you please detail, what "performance fixes" you identified.

I installed ST9MP5 now. The feeling is about the same as with MP4: SE is still incredible slow. Editing a PART within an assembly lasts still about 2 seconds. Closing the part and going back to the assembly again another 2 seconds. Even activating a feature (hole, plane ...) lasts about one second. That means waiting instead of working. Some posts ahead, I described with an example exactly what I mean. Meanwhile I upgraded my hardware. But it is still absolutely no fun to work with ST9.

Peter

 

 

Re: ST9 performance is worst than ST8!


Peter24 wrote:

@LauraWatson, @KeithCain

>we were able to identify a couple of performance fixes. 

Could you please detail, what "performance fixes" you identified.

I installed ST9MP5 now. The feeling is about the same as with MP4: SE is still incredible slow. Editing a PART within an assembly lasts still about 2 seconds. Closing the part and going back to the assembly again another 2 seconds. Even activating a feature (hole, plane ...) lasts about one second. That means waiting instead of working. Some posts ahead, I described with an example exactly what I mean. Meanwhile I upgraded my hardware. But it is still absolutely no fun to work with ST9.

Peter

 

 


Solid Edge never been that fast in entering a part to edit in assembly neither returning back. In ST9 it went worst.

 

Maybe is something related to the "tabs" ?

 

I feel the same pain (slowness) when swithching from an open document to another.

 

Is it possible to turn "tabs" off ?

 

Thanks

Re: ST9 performance is worst than ST8!

When working with the actual MP6 I remarqued some improvments concerning the Microsoft "backstage UI". Opening of the menus has become significant faster now, when you click on the SE-button, even if they're not cached. But these delays are minor, because you can easyly avoid them by using shortcuts. But I still feel the main subject of critique at work. 

Maybe is something related to the "tabs" ?

You're right. The screen during switching between documents has similar behaviour to the behaviour described below (flickering)

The first difference between ST8 and ST9 I see, is the flickering of the "Teilebibliothek" and the "Pathfinder" during the change between "assembly view" and finally edited part. I didn't remark it in ST8. ST9 here does sth. significant different to ST8, what uses a lot of valuable time.

Second: There is a huge difference, whether I edit a PART in a ASM, or I open from the ASM. There seems to be only slight difference, if the rest of the ASM is deactivated or hidden: Clicking a feature (plane, hole ...) lasts 2+ seconds (edited) or <<1 second (opened). 

These delays become massively annoying, if you really work with SE and not just play around a little bit.

Peter

Highlighted

Re: ST9 performance is worst than ST8!

Not have contributed to much to the investigation yet but since working with ST9 and ST8 over a long stretch of time now the main difference between the UI's is the front and back door UI in ST9 vs ST8.

 

Could the delays be related to this structural change in the GUI at the code level?  Its just an observation as I'm by no means a code writer.  Just seems like an obvious place to look?

 

Cheers

Phil

ST9
WIN 7Pro 64bit
DELL T5810 3.7-4Ghz 32Gb ECC