Showing results for 
Search instead for 
Did you mean: 

AMESim to Simulink interface problem




I have been trying to create s function from the mex file generated in amesim. When I used the amesim s function this error occurred.




Then I run a standard s function and it gave me this error when I tried to run the model




While it doesn’t actually print any error messages in the matlab command window. The amesim mex contains a very simple pneumatic model with temperature and pressure input with a orifice.

I have tried to create a simple model in amesim just using signals and it works, but I just can’t get it to work for pneumatic library.


I realise that I’m not giving much detail, so if you need any more specifics let me know.


EDIT:  Solved, I have set path for the amelic150.dll and the license dll for my library


Re: AMESim to Simulink interface problem

Siemens Experimenter Siemens Experimenter
Siemens Experimenter



The real problem is that your 'AME' environment variable is not correctly set. Indeed, check that the 'AME' environment variable exists and that it is set to the correct Amesim installation folder ('C:\AMESim\v1500'). Then there is no need to set the MATLAB path and the simulations should work fine.