Cancel
Showing results for 
Search instead for 
Did you mean: 

AWC-Unable to view attributes which has to be filled during custom item creation

I am unable to create any custom parts in AWC because attributes that needs to be filled during the part creation are not loading,Please find it in the attached image.

 

Our custom item types have its own stylesheets which are different from OOTB part creation stylesheet.

Description:

 

When we create any part in TC, it asks about some attributes.

 

When we enter those value, part is created.

 

But in our case, we created custom parts.

 

Those parts have its own custom attributes which has to be filled during part creation.

 

But we are facing the following issue-

 

When we are creating part in AWC, those attributes are not loaded.

 

It continuously shows the same message as - LOADING....

 

So we are unable to create any custom parts in AWC.

 

But this issue doesn't occur during part creation in rich client.

2 REPLIES

Re: AWC-Unable to view attributes which has to be filled during custom item creation

Valued Contributor
Valued Contributor

@Anudeep_Reddy

 

I had the similar issue displaying mandatory attributes in AWC

 

I got the below solution from GTAC and they also documented the same in GTAC solution center 001-9105502

 

1) Download the named reference from the XMLRendering dataset Awp0ItemCreate (This is the Active Workspace stylesheet for the OOTB Item).


2) Rename it to Awp0CustomItemCreate


3) In Teamcenter Rich Client create a XMLRendering dataset  (File->New->Dataset) called Awp0CustomItemCreate importing Awp0CustomItemCreate.


4) Open dataset Awp0CustomItemCreate in the Viewer and added the custom required attributes


5) Since these attributes are from the the CustomItemRevsion add them on 
the stylesheet with "revision:" in front of it. 
 e.g. <property name="revision:cust_attr1"/>


6) Create a preference called 
 AWC_CustomItem.CREATERENDERING with the Value Awp0CustomItemCreate


Re-login to Active Workspace. 
The user should be able to see the custom required attributes on the CustomItem Create form  

 

 

Regards
Rafa

Re: AWC-Unable to view attributes which has to be filled during custom item creation

thanks for the immediate solution.I'll post the results soon.