Cancel
Showing results for 
Search instead for 
Did you mean: 

AWC indexing issue

Pioneer
Pioneer

Hey Guys,

  

I'm facing issue with indexing. E.g. we have an item name(object_name) "T966 D66 facemill BT50". When we try to search in AWC by entering "D66 facemill", we get correct revision but when we try to search using "T966*" we don't get any result.

  

Any idea why is it so and how it fix it?

  

Thanks in advance.

  

Br,

Rupesh

3 REPLIES

Re: AWC indexing issue

Valued Contributor
Valued Contributor

Hi Rupesh,

 

Perform these steps ,this will ensure that the Solr Schema and Teamcenter processes access up-to-date information.

 

Active Workspace Re-index Steps
--------------------------------------
1. Transform Schema

C:\tc_root\solr-5.1.0> TcSchemaToSolrSchemaTransform %tc_data%\ftsi\solr_schema_files\

2. Stop Indexing Service

C:\> net stop "Active Workspace Indexing Service"

3. Start Indexing Service

C:\> net start "Active Workspace Indexing Service"

4. Stop Teamcenter Server Manager

C:\> net stop "Teamcenter Server Manager Tc11_PoolA"

5. Clear the Temp application cache

C:\temp> rmdir V11000.2.0.20_20160504.00 /s /q
C:\temp\2> rmdir V11000.2.0.20_20160504.00 /s /q

6. Start Teamcenter Server Manager

C:\> net start "Teamcenter Server Manager Tc11_PoolA"

7. Re-Index Objects (REINDEX)

C:\tc_root\TcFTSIndexer\bin> runTcFTSIndexer.bat -task=objdata:clear
C:\tc_root\TcFTSIndexer\bin> runTcFTSIndexer.bat -task=objdata:index

8 Run the object data sync

C:\tc_root\TcFTSIndexer\bin> runTcFTSIndexer.bat -task=objdata:sync -interval=25

Regards
Rafa

Re: AWC indexing issue

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

@Rafa2, If you are curious about why C:\Temp\2 gets created (and can cause Tc login to fail if missing) then review the attached doc. Enable "Do not use temporary folders per session" to stop creating session id sub-folders in TEMP. It is much easier to manage when its not a moving target (2/3/4/etc.).


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: AWC indexing issue

Pioneer
Pioneer

Hi Rafa,

 

I just restarted indexing service and it worked for me. Not sure why it didn't work before service restart.

 

Br,

Rupesh