cancel
Showing results for 
Search instead for 
Did you mean: 

AWC visualization with SSL Encryption.

Valued Contributor
Valued Contributor

Hi All,

 

Does anyone tried AWC visualization on encrypted environment.

 

Requirement is to View JT in AWC client which is SSL encrypted, FMS is also encrypted.

 

Using AWC 3.2.1 with Teamcenter 11.2.2.1.

 

I am successful to setup the same on an unecrypted environment where FMS is also not encrypted.

 

When i tried this on a SSL environment where FMS is also encrypted getting "Failed to Load Viewer" error.

 

Just to eliminate either of SSL or FMS. Tried on a non-SSL environment where FMS is encrypted, but still facing same error.

 

As per my observation the process invoved in this is, when a JT is selected to view in AWC it connects with visualization server manager  process (visview.exe) and then triggers FCC process (java.exe) which will build the rendered JT and send back to AWC.

 

In both the cases SSL+FMS and just FMS, able to reach till a FCC process being triggered, but not able to view JT.

 

In either way we have .cer files, packed as cacerts and maintained in jre/lib/security folder of Pools+Jboss+vispool+FMS+Corporate.

 

Does vispool expect certificates in a different format?

 

Also All_CA_Certs.pem file is getting created in logs, even if the environment is unencrypted, what is the relavence of it?

 

Can someone please suggest me a way to overcome issue with encrypted environment.

 

Thanks
Phani

1 REPLY

Re: AWC visualization with SSL Encryption.

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

You will need to do some additional changes while building your awc application file. Open these two below files and update the entry for SERVERSIDE_SOA_FULLPATH.

Edit the following files: same file is in two locations.

 

<YOUR TC_ROOT>\aws2\stage\out\javac\base\com\teamcenter\thinclient\internal\config\URLConstants.java

<YOUR TC_ROOT>\aws2\stage\repo\gwt\base\src\com\teamcenter\thinclient\internal\config\URLConstants.java

 

String SERVERSIDE_SOA_FULLPATH = "https://YourhostnameSmiley Tongueort/tc"; //$NON-NLS-1$

 

Rebuild your awc.war file and deploy it. If this does not work - then you will also need to see that TCCS is working properly on the visserver by running %FMS_HOME%\startfcc

 

Hope this helps.

 

Line 25:

String SERVERSIDE_SOA_FULLPATH = "http://10.0.1.91:8080/tc"; //$NON-NLS-1$