cancel
Showing results for 
Search instead for 
Did you mean: 

Automatic indexation

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hi everyone,

 

I'm trying to set an automatic indexation of the new data in my active workspace installation.

So far I tried with runTcFTSIndexer -task=objdata:sync -interval=30 with the runTcFTSIndexer launched as a service.

But it seems like the new data is not indexed. Do you have any idea how I can do this ?

 

PS: When using objdata:index or reindex, my data is correctly indexed.

 

Thank you in advance,

 

Best regards

 

Benjamin

 

5 REPLIES

Re: Automatic indexation

Siemens Phenom Siemens Phenom
Siemens Phenom

When I did this last time I ws not able to run objdata:sync as a service. I had to start it on cmd. Does it work for you if you start it on cmd?

xtof

Re: Automatic indexation

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
I'm not running Active Workspace yet but isn't the indexer Apache SOLR? The FTS (Full Text Search) is Autonomy and indexes specified types for the rich client. FTS is pretty robust but not nearly as capable as SOLR. SOLR is harder to administer but seriously powerful. While FTS will work for the rich client, as far as I know, it will not work for Active Workspace. You have to use SOLR for that.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Automatic indexation

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

I'm not sure because I was following the active workspace deployment guide.

It is giving information about indexing data using FTS. When doing it with objdata:index, my data is correctly indexed in active workspace.

My goal was to have the same comportement but as a service running by various interval.

Re: Automatic indexation

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

As a service, I can see it running but the new data isn't indexed. In a cmd as well.

You can see in the attachment how it run.

Is objdata:sync really the command to indexed the new document an items created in active workspace ?

Re: Automatic indexation

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Guys, I solved my issue. The problem was coming from the triggers. During the installation, we forget to do the install the database triggers as mentionned in the deployment guide of Active workspace.

Now it is finding my new data when the runTCFSindexer is running with an interval.

 

Thank you guys for your answers Smiley Happy