Showing results for 
Search instead for 
Do you mean 
Reply

BMIDE Error when generating the code - SOA Customisation

Hi All,

 

I am trying to create a Service with BMIDE in Teamcenter 10.

 

Followed the steps as mentioned in the document without adding my custom implementation code.

 

When tried to generate the code for new my service,i am getting back an error saying E:\app\BMIDE\C9SoaTest\output\generated\C9SoaTestLibraryClient\gwt\java does not exist.

 

Checked the ant files which got auto-created during project  setup and it seems there is no ant task to create the folder.

 

Did anyone face this issue? Any suggestions please?

 

cheers

Bala

5 REPLIES

Re: BMIDE Error when generating the code - SOA Customisation

Hi,

 

I'm not sure what the cause is but somethimes BMIDE misbehaves - what I usually do then is to delete the build and output folders and generate the code again.

 

You could also try to right click on the code generation->Services-><your service> in the Extension tab and choose GenerateCode->Service Artifacts.

 

Currently that's the only thing I can think ofSmiley Sad

 

BR

Frank

Re: BMIDE Error when generating the code - SOA Customisation

Hi Frank,

 

I tried the your suggestion and it did not make any difference.

 

Still gettting the error.

 

cheers

Bala

Re: BMIDE Error when generating the code - SOA Customisation

Hi,

 

please check your client bindings by:

 

1. Click the nevigator tab in the BMIDE

2. Right click the project->properties

3. Teamcenter->Build configuration->Service Client bindings

 

Make sure you only choose the bindings you need. After you make changes to this I would generate again with the instructions from my previous post. Maybe try to set or unset the GWT binding.

 

BR

Frank

Re: BMIDE Error when generating the code - SOA Customisation

Hi Frank,

 

I tried your suggestion and it did not work.

 

Also noticed that BMIDE is creating the stub folder structure for all bindings first irrespective of the selection we make.

 

Looks like i was using 2Tier BMIDE which was the cause for my issue.I tried using 4Tier BMIDE and issue got resolved.

 

Thanks a lot for your suggestions.

 

Thanks

Bala

Re: BMIDE Error when generating the code - SOA Customisation

Hi,

 

I am also facing the same issue even if I try 4tier it is not working. Please let me know for the solution.

 

Thanks,

Rananjay