Cancel
Showing results for 
Search instead for 
Did you mean: 

Could not load all ISAPI filters for site 'JBOSS_IIS'. Therefore site startup aborted.

Experimenter
Experimenter

Hello,

 

I am configuring SSo with Kerberos for Teamcetner 11.2.2 

Could someone please suggest what is the rootcause for this error

 

Steps to reproduce:

1. Created new site and configured ISAPI_Redirector file

2. Followed the steps provided as per the standard document.

3. Started the site and getting the mentioned error.

 

Pleae help!!

2 REPLIES

Re: Could not load all ISAPI filters for site 'JBOSS_IIS'. Therefore site startup aborted.

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor
I just finished installing SSO w/Kerberos on Tc11.2.3_patch_1 (Tc11.2.3 has a bug that won't dismiss the background image). I abandoned JBoss as part of the solution and went with Tomcat instead.
1. Install Tomcat (apache-tomcat-8.0.47.exe) by selecting defaults.
2. Install ISAPI Redirector (tomcat-connectors-1.2.42-windows-x86_64-iis.zip) with the same folder structure as the JBoss solution. I used E:\Siemens\Jakarta, \bin, \conf, \logs, \wwwroot
3. Disable Tomcat authentication <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" tomcatAuthentication="false" />
4. Configure Jakarta, registry isapi_redirect.reg, isapi_redirect.properties, workers.properties, uriworkermap.properties.
5. Create website in IIS, tomcat-iis, port 8128. Set Authentication, ISAPI Filters (jkfilter).
6. Add virtual directory, Jakarta, E:\Siemens\Jakarta\bin, Set Handler Mappings.
7. Restart IIS from an elevated command prompt, iisreset.
8. Validate by opening in IE, http://<your_server>:8080/, should see Tomcat web page.
9. Now you can configure tc.war, ls.war and id.war in INSWEB then deploy to Tomcat webapps dir.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Could not load all ISAPI filters for site 'JBOSS_IIS'. Therefore site startup aborted.

Experimenter
Experimenter

Thanks for the help..

Will execute the steps as suggested....