Cancel
Showing results for 
Search instead for 
Did you mean: 

Dataset named references not being created during Drag and Drop

Valued Contributor
Valued Contributor

I'm trying to configure file behavior between a few different Femap analysis output files and some custom datasets I recently created. I've got everything behaving about like I need it to, but for some of my file types the Named References are not being created after the drag and drop operation.

 

An empty dataset is created of the appropriate type, but no data actually gets copied in from my local file system (as shown in the attached screenshot).

 

I'm having trouble determining if the behavior needs to be corrected from preferences in the RAC or from BMIDE...anyone have experience with this issue? I'm running Teamcenter 11.4.

 

drag and drop dataset_named refs.jpg

7 REPLIES 7

Re: Dataset named references not being created during Drag and Drop

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Use the preference DRAG_AND_DROP_default_dataset_type
For instance, to add the macro excel, add "xlsm:MSExcelX" to the list.

And if you need to add it to the viewer...
defaultViewerConfig.VIEWERCONFIG: add value "MSExcelM.MSExcelViewer=excel"

Hope this helps.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Dataset named references not being created during Drag and Drop

Valued Contributor
Valued Contributor

Thanks Randy,

I'd actually already found that one from a previous post...I did need to set that preference (prior to that the files were coming in on incorrect types) but that didn't fix the named references issue. Here's what I have; it DID fix the dataset type association, but isn't creating the named reference on drag & drop file creation.

 

I forgot to mention in the first post...I CAN go through the file>new dataset dialog, manually create a dataset, and associate a named reference there with success. I just don't think that's intuitive enough for most of my users, so was trying to get the simpler drag/drop approach to work correctly. 

 

drag and drop default types.jpg

Re: Dataset named references not being created during Drag and Drop

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
See step 3.
https://docs.plm.automation.siemens.com/tdoc/tc/12.2/help/#uid:xid1616387

Check the Dataset Type Definition in BMIDE?
https://docs.plm.automation.siemens.com/tdoc/tc/12.2/help/#uid:genid_dragging_and_dropping_data_27_8...

I can't find any other specifics like real name vs display name, etc.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Dataset named references not being created during Drag and Drop

Gears Phenom Gears Phenom
Gears Phenom

@jchurch = can you share screenshots of the BMIDE configuration for this dataset and its tool? 

Jamie Griffis | PLM Solution Architect | Engineering USA

Re: Dataset named references not being created during Drag and Drop

Valued Contributor
Valued Contributor

Sure Jamie, see attached.

 

Just a little background - I'm creating datasets based on OOTB CAE template datasets, because my company has not yet implemented TC Sim. We DO want to start archiving sim data in Teamcenter in the meantime though.

 

So far, I've got one out of three datasets behaving as I need it to...for now I just want the data to be viewable in the system default Text editor (Notepad at my site). I may be almost there, I just noticed the two datasets that are not getting Named References attached do not have any Tool Actions defined in BMIDE. I wouldn't have thought this would interfere with the creation of Named References, but it's the only thing I can see between the two datasets that is fundamentally different.

 

I was just about to add References & Tool Actions to the two problem datasets, and redeploy, unless anything else jumps out at you that could be the culprit. Screenshots below.

 

 

analysis bulkdata.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

modfem data.jpg

 

 

 

 

 

 

 

Re: Dataset named references not being created during Drag and Drop

Gears Phenom Gears Phenom
Gears Phenom

@jchurch - That was exactly what I wanted to see. Not having the ToolActions for Open or OpenWith defined will cause this type issue. Define those actions and restart the services then check those named references. Let me know.

Jamie Griffis | PLM Solution Architect | Engineering USA

Re: Dataset named references not being created during Drag and Drop

Valued Contributor
Valued Contributor

This fixed my issue @Jamie_Griffis! After adding my tool actions the named references come into Teamcenter as expected during drag and drop. Thanks very much for the help.