Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: E-mail Notification Problem

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Check that the ports are not blocked on the Tc11 server (new server) and that the new server is authorized to talk to your mail server. This sounds like a permissions issue and not configuration.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: E-mail Notification Problem

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Please raise IR to get GTAC help to sort this issue.

Re: E-mail Notification Problem

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @ArthurRM ;

Firstly ,Many thanks for helps.

When i use the tc_mail_smtp utility on TC 10 i did not get any error . I can send test mails to recipients.

yes i got the different results when trying to send an e-mail to recipients.

Could you explain or send example for tc_mail_smtp utility -testmode ?

 

Best Regards

Gurkan

Re: E-mail Notification Problem

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @ArthurRM ,


I found how to use -testmode on tc_mail_smtp .

I did first test on TC 10 . I create a folder on desktop which is Gurkan  then i put the test.txt file in . Then i opened the TC_cmd to wrote that script ;

%TC_BIN%\tc_mail_smtp -to=user1@xyz.com.tr -server=mail.xyz.com.tr -subject="Hello" -user=user2@xyz.com.tr -testmode=C:\Users\test\Desktop\Test.txt -port=25

Then i check the Test.txt file , it includes the all these test mail information like below ;

 

2018-11-19_14h37_44.png

Also i tested it on TC 11 Server with same script you can find the txt content at below.

2018-11-19_15h23_18.png

 

Best Regards

Gurkan

Re: E-mail Notification Problem

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hi All

 

I am also observing the same issue. However, with the tc_mail_smtp.exe the mail is working fine

but with tyhe handler  EPM-notify  I am getting the same issue of "Invalid function argument". I am using TC11.5.2

 

Ambuj

 

 

Re: E-mail Notification Problem

Siemens Genius Siemens Genius
Siemens Genius

Hi,

 

Mail_server_name - ?

and set Mail_from_OS_address, as YouLovelyTeamcenter@blablabalbal

 

 

All the best, Alexey.
Highlighted

Re: E-mail Notification Problem

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Yes

 

Both the preferences are set and have the values.

 

Ambuj

Re: E-mail Notification Problem

Siemens Genius Siemens Genius
Siemens Genius

Do you have 2 tier rich client?

All the best, Alexey.

Re: E-mail Notification Problem

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Yes, It is a 2 Tier Rich Client

 

Ambuj

Re: E-mail Notification Problem

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @Ambuj ,

 

Actually i could not solve that problem , still i have a this problem too. I'm not sure but maybe the mail server systems was changed . As you know previously Teamcenter use port 25 to reach mail server ,but at now , mail server systems are not allowed to use port 25 cause of the security reasons. So , we use 587 (generally) to reach mail server and the mail server systems are required to authorization while you are trying to send mail to users by using port 587 on mail server. I'm not expert on the mail server systems but when you fill the Mail_From_OS_adresses but there is no option to fill the password information. I don't know , if we can achive to ignore the user authorization when blabla@blabla.com mail adresses is reaching to mail server to send mail , the problem will be solved.

 

Best Regards
Gurkan