Cancel
Showing results for 
Search instead for 
Did you mean: 

Engineering utiliy Exception:POM002

Creator
Creator

Hi,

     I am trying to install Teamcenter 11.2. During installation I got the error as "EngineeringUtilityException:POM002".When I saw in install_config log file, it is failing to run the "bmide_schema ALL"utility.

I ran that BMIDE schema ALL utility manually by setting the Teamcenter environment variables. It generated a syslog file with the following message,

                           License Error: -39

                          DEBUG - 2018/02/23-13:44:08.646 UTC - NoId - Flexlm attach error:  -39:               User/host not on INCLUDE list for feature.

 

But, when I try to ping to that license server, it is pinging.

Here, I have enclosed install_config log file.        

Please can anyone suggest a solution for this. Thank you.

7 REPLIES

Re: Engineering utiliy Exception:POM002

Phenom
Phenom

Good afternoon.
Does your license server use the options file? If so, you need to configure it.

Re: Engineering utiliy Exception:POM002

Creator
Creator

Hi,

 

Thanks for reply, our license server was in remote. It is using options file. We checked in options file also that whether our hostname and our IP had been added. It is added, but during installation same utility failure occurred.

 

 I checked in configuration.xml file, in that errorFile value it points some tem8374~9.log file. When I saw in that file it mentioned "Processing <install> of feature Teamcenter Foundation failed: com.teamcenter.install.tceng.struct.exceptions.ced.EngineeringUtilityException: One of the Teamcenter utilities has failed."

 

Please find attached bmide_schema.syslog file and install_config log file.

 

Please, help to resolve this issue. Thank you.

Re: Engineering utiliy Exception:POM002

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

Did you make sure that the license server version and license file are compatible with the version of Tc that you are attempting to install? 

Re: Engineering utiliy Exception:POM002

Phenom
Phenom

Hi, I found in the install_config file attached only and did not find bmide_schema.syslog

See also D: \ Siemens \ Teamcenter11 \ logs \ 1802231900 \ tc_install.log for errors

Re: Engineering utiliy Exception:POM002

Creator
Creator

Hi,

 

 We are trying to install Teamcenter 11.2, the license server which they provided us was version 12 and it will be compatible with all lower versions.

 

PFA bmide_schema log file and screenshot of tc_install log file.

Re: Engineering utiliy Exception:POM002

Phenom
Phenom
What features did you open in the options file? Judging by your mistake, you need to give access to Feature: server_id

License Error: -39
  Unknown Error Value.
FLEXnet Error 0 has occurred.
For further information, refer to the FLEXnet Licensing End User Guide, available at "www.flexerasoftware.com" .Feature: server_id

FLEXnet error: 0.0.

Re: Engineering utiliy Exception:POM002

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor

License error -39 may not mean the same as the FLEXnet Error code. FLEXnet Error -39 is "User/host not on INCLUDE list for feature" however the FLEXnet Error code is actually reported as "0".

FLEXnet Error 0 has occurred.

 

Further in the log, I think the real problem is being reported. When the database is initially populated, a special user named "otto" (password "matic") is created in the SYSTEM group. Later in the install process, this user is removed and "infodba" is created in the DBA group (when license is validated). The FATAL error in the log is "Failed to find 'otto/system' member."

 

Looks like your installation is trashed.

Capture.PNG


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4