Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Error of the awc 4.1.4 login page and VisPoolAssigner

Creator
Creator

Hi,All
I installed awc4.1.4 by? j2ee on tc12.0. The middleware is weblogic12.2.1.3.
The war package can be generated and deployed normally, but there will be problems when accessing the web page.

it show a internal error,console show a 404 errorawc5error.jpg

<Error> <HTTP> <BEA-101019> <[ServletContext@
1732049500[app:awc module:awc.war path:null spec-version:3.1]] Servlet failed wi
th an IOException.
java.io.IOException: An existing connection was forcibly closed by the remote Host
        at sun.nio.ch.SocketDispatcher.write0(Native Method)
        at sun.nio.ch.SocketDispatcher.write(Unknown Source)
        at sun.nio.ch.IOUtil.writeFromNativeBuffer(Unknown Source)
        at sun.nio.ch.IOUtil.write(Unknown Source)
        at sun.nio.ch.SocketChannelImpl.write(Unknown Source)
        Truncated. see log file for complete stacktrace
>

This is my boot sever bat

start /D "C:\Siemens\pool_manager\confs\config1" mgrstart.bat
TIMEOUT /T 120
start /D "C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain" startWebLogic.cmd
TIMEOUT /T 150
start /D "C:\Siemens\VisDataServer\Program\" VisDataServer.exe
TIMEOUT /T 45
rem start /D "C:\Siemens\vispoolmanager" run_visservermgr.cmd
rem TIMEOUT /T 45
start /D "C:\Siemens\solr-6.2.1" runSolr.bat
endlocal

Another problem is that my visualization server can't be started. I have uninstalled this server function. Here is a screenshot of this problem.awc可视化.jpg

[ 2019/06/25 18:54:42.326 Inain IERROR ]:UisServerHanager-ZJLY3DESERUER

:55577:Could not connect to UisPoolAssigner-ZJLY3DESERUER:55566.Retrying ..…

[ 2019/06/25 10:54:43.338Inain :ERROR 1:UisServerManager-ZJLY3DESERUER

:55577:Could not connect to UisPoolAssigner-ZJLY3DESERUER:55566.Retrying ..…

[ 2019/06/25 18:54:44.344 Inain IERROR 1:UisServerHanager-ZJLY3DESERUER

:55577:Could not connect to UisPoolAssigner-ZJLY3DESERUER:55566.Retrying...

Thank you for your reply and attention.

4 REPLIES 4

Re: Error of the awc 4.1.4 login page and VisPoolAssigner

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

Hello, the error of the Vis server manager is also resolving in this discussion, there are several links that can help you.

 

https://community.plm.automation.siemens.com/t5/Teamcenter-Users-Forum/error-with-vis-server-manager...

 

Re: Error of the awc 4.1.4 login page and VisPoolAssigner

Creator
Creator
Before deploying awc.war, do I need to deploy tc.war, the 4-thin-tier war package?

Re: Error of the awc 4.1.4 login page and VisPoolAssigner

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
You need to have a functioning 4tier environment before AWC logins will work. And then Visualization, which is last in the chain of applications.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Error of the awc 4.1.4 login page and VisPoolAssigner

Creator
Creator

Thank you Randy , I understand . Before  Roman65 responded to me that  four thinClient was marked as deprecated. My  4-tier war tc.war package has been generated, but there was a 404 error after deployment on weblogic . The GATC engineer was already helping me, but we didn't see the problem. Thank you for your thoughts on troubleshooting problems here!