Cancel
Showing results for 
Search instead for 
Did you mean: 

Error while Patching TC 11.2.0 TO TC 11.2.3

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

I tried to patch TC 11.2.0 to TC 11.2.3 and have this error below, any idea on this error ?

thanks.

 

 

 

image.pngimage.png

 

 

1 REPLY

Re: Error while Patching TC 11.2.0 TO TC 11.2.3

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
It can be many things but likely is the database compatibility setting:
- Open the MS SQL Server Management Studio
- Select that database that is being used for Teamcenter
- Right-Click on the Teamcenter database and select Properties
- In the Database Properties window/Select a page, click on options
- The current compatibility will be listed in the Compatibility level box.
- Change this to be the MS SQL 2012 server to match the version that this database is now being run on.
- Restart or refresh that database instance and then restart the Teamcenter upgrade.

The database calls have added the "TRY_CONVERT" command which is not available in earlier versions of the database:
MS SQL Version - Compatibility Level
2008 - 100
2012 - 110
2014 - 120
(you can Google it) If you are running 2012 then set the comp lvl to 110.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4