Cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to install Teamcenter Visualization(Emebedded)

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

I installed, 2-tier, 4-tier , after I finished my all installation and login successfully, I added the teamcenter visualization (embedded) from environment manager and deployed it successfully. However when I double click on "Teamcenter 4-Tier Rich Client" icon, to open teamcenter, it encounters an error as below. I could login successfuly, but I couldn't use Visualization embedded. Also I put my configurations screenshots below (2-tier and 4-tier). Thanks in advance.

 

VisualizationError.JPG

VisEmbeddedOtwError.JPGVisMockup.JPG
4-tierVisualization.JPG

4 REPLIES

Re: Failed to install Teamcenter Visualization(Emebedded)

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Your TEM screenshot shows both embedded and standalone. These are mutually exclusive. For standalone, you simply point to where TcVis is already installed (like your Windows explorer screenshot). For embedded, you point to the msi which installs TcVis as part of the client (like your Web Application and Context Parameters screenshot). Which one are you going to use, standalone or embedded? You can't point embedded to an already installed standalone. Review the otw_install*.log for clues on the issue (In C:\User\...\AppData\Local\Temp).

Another quick comment. The 2-tier install is using TEM. The 4-tier install is using INSWEB. Hopefully that helps you separate the two and where you should look for issues.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Failed to install Teamcenter Visualization(Emebedded)

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

I uninstalled standalone, it still encounters the same error. Then I uninstalled embedded also, from 2-tier and 4-tier. Everything is working good. In viewer tab, I could see the cad part. It is workin good. I didn't understand how this happened but everything is ok. Thank you very much. Have a great weekend.

Re: Failed to install Teamcenter Visualization(Emebedded)

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
You don't need TcVis (standalone or embedded) to view CAD files in the Viewer tab. Teamcenter without any TcVis still works because the "base" level of TcVis is installed by default. You can see this in the plugins\FoundationViewer folder. However, if you need more functionality (you installed Professional before) then you will need either the standalone or embedded version. I like using Standalone when I need something greater than the foundation viewer (base). Now you know.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Failed to install Teamcenter Visualization(Emebedded)

Valued Contributor
Valued Contributor

Good afternoon, try to share the folder with the Visualization installer and specify the full network path, including the MSI file, for example \\your_pc_name\visualization_installer_folder\file_name.msi in the settings:


TcVisEmbeddedInstallImageWindows64Location
TcVisEmbeddedInstallImageUNIXLocation

 

 

filepath.jpg

 

 

Before running the 4-Tier client, make sure that this network path is available and that it does not request a password when accessing it.