Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hello,

I installed two tier and four tier (server) and also I integrated it with NX. I import some templates, on Server all TC-NX processes are working good. However on client there is a problem. When I try to open NX from TC on client, it encounters an error "Failed to start application UGManager". After that I made some things as some suggestions as the link below.

https://community.plm.automation.siemens.com/t5/Teamcenter-Administrators-Forum/ERROR-Failed-to-star...

 

However the error still going on. I put some screenshots and log file at the attachments. Thanks in advance.

env_var_baseDir.jpgenv_var_UgiiRootDir.jpgenv_var2.JPGmissingnTier.JPGregedit.JPGugiiBaseDir.jpgUGManager.jpg

9 REPLIES

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
You are launching NX using the icon in Teamcenter (and not by directly running start_nxmanager.bat), yes?

UGII_ROOT_DIR is obsolete and can be removed. The problem is in start_nxmanager.bat. The NTIER_ARG isn't being passed in (as %1). The value should be either "2-tier" or "4-tier". Make sure to fix the value for UGII_BASE_DIR or simply comment out the line. Also comment out the FMS_HOME line.

The UGII_BASE_DIR is set as a system environment variable. Make sure you reboot the computer after installing NX or it won't be able to read this value.

Attach start_nxmanager.bat if you are still having trouble.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hello @RandyEllsworth thanks for your answer. Yes,I am launching NX using the icon in Teamcenter. I made the changes that you suggested, also there isn't FMS_HOME variable in environment variable. The error still continue. I put the  start_nxmanager.bat at the attachment.

Thanks in advance.

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

You are using an older NX version (NX9) than I am (NX11). So you still need UGII_ROOT_DIR. Which error continues?
1. Missing N-tier parameter
2. UGII_BASE_DIR must be set

 

1, 2, or both?


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

only "Missing N-tier parameter" error continue. After I close it "Failed to start application UGManager" pop up encounters. Additionally, I use NX12.0 @RandyEllsworth thanks.

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Whoops. You have specified the wrong version if you are using NX12. The start_nxmanager.bat you attached earlier shows V27.0 which is NX9. V29.0 is NX 11 which means NX 12 must be V30.0. You'll need to fix this line...
start "Teamcenter Integration for NX" /B %UGII_ROOT_DIR%\ugs_router -ugm -enable_cancel -version=V27.0 %*

Should be -version=V30.0

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hello again,

I made it V30 but unfortunatelly it doesn't work and the same issue. Afterthat I checked server again and on server everything is okey. Thus I think if I uninstall teamcenter 4-tier on client machine and reinstall it again, maybe it solve the problem. I made that but now there is no start_nxmanager.bat doc in "C:\Program Files\Siemens\Teamcenter\OTW11\rac" (Client machine) . I copied the start_nxmanager from server and pasted it in "C:\Program Files\Siemens\Teamcenter\OTW11\rac"  path, in client machine. When I double click on it "missing n-tier parameter" error encounters again. I put it at the attachments. Also I put some screenshots about regedit from client machine,below.

Thanks.

(start_nxmanager doc is from server and on server tc-nx is working good together without any issue.)

regeditNew.JPGugportalFileNew.JPG

 

 

 

 

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
These work-arounds you are hurting you and our ability to help you. A missing start_nxmanager.bat is an indication that you have not installed the NX integration feature on the client. Copying the script is not enough as the NX Integration feature actually does more than just add the file.

Have you installed INSWEB on the web server before? INSWEB uses ICD's to build web applications (like ANT). The nx4t.icd has a target "new_solution_win" and tag "regfile". The regfile section lists the registry entries that should be applied. The nx4t.icd demonstrates what the NX Integration adds to the client.

So the real question is, why doesn't your client install include the NX Integration? I assume you are using TEM to install the client software and not doing anything out of the normal. Make sure your check the NX Integration in TEM. It would be helpful to us if you include a screen shot of TEM on the "Old Configuration" page with the features expanded (before the "Feature Maintenance" screen). In the "Features" screen, expand "Teamcenter Integration for NX" and select "NX Rich Client Integration". That should add the start_nxmanager.bat, nxmanager_portal.bat and add the registry entries.

One last question...
Is this the ONLY rich client installed on the client machine? In other words, you don't already have Production or Test or Development rich clients installed. No multiple environments on the same machine?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Yes, I installed INSWEB on the web server. I put the environment manager and INSWEB screenshots below. There

was a missing in INSWEB "NX Manager for Rich Client 4-Tier", I choose it and click ok, it finished the processes. After I did this when I open teamcenter it started to encounter a pop up , as the screenshot ERROR, below. In client machines also this error encounters. My NX is "c:\Program Files\Siemens\NX 12.0" on both of server and client. 

For your last question;I installed NX 12.0 then I installed 2-tier and finally I installed 4-tier (with INSWEB). I didn't install any other configuration or programme.

 

EnvironmentManager.JPGINSWEB.JPGTcNXIntegration.JPG

Re: Failed to start application UGManager ( Missing n-tier parameter )

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

I modified INSWEB as the screenshot below, then everything is ok. NX is opening from Teamcenter now. Thank you very much for your help.

 

INSWEB_NXConfigurationDegisiklikOncesi_paint.jpgmodifyNxpaint.jpg