Showing results for 
Search instead for 
Do you mean 
Reply

How to set where the translated dataset is placed?

Hello experts,
I've configured Dispatcher to translate UGPART to CGM and it looks fine.
But the generated cgm dataset is placed under UGPART and I need these dataset to be placed under Item Revision.
It's possible to set this configuration/preference?

9 REPLIES

Re: How to set where the translated dataset is placed?

you need to set 2 prefs:

 

<transServiceName>_<SourceDatasetType>_ets_dst_relation_to_src

Value: Relation name for ex. IMAN_specification

 

Specifies the relation type of the relation to be created between the source dataset item revision and the destination dataset. If the source and destination dataset types are the same, this preference is ignored. You must specify this preference if the source and destination datasets are different; otherwise the service configuration is invalid and an error occurs during translation.

 

<transServiceName>_<SourceDatasetType>_ets_dst_relation_to_src

 

specifies if a relation must be created between the source dataset and destination dataset. This should be set to False in your case.

Re: How to set where the translated dataset is placed?

The first preference should be:

<transServiceName>_<SourceDatasetType>_ets_dst_relation_type


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: How to set where the translated dataset is placed?

thanks @RandyEllsworth for the correction.

Re: How to set where the translated dataset is placed?

I've tried here but didn't work...
I'm using the nxtocgmdirect module... maybe this module is not compatible?

Re: How to set where the translated dataset is placed?

The CGM should be stored in a DrawingSheet dataset by default? Not sure why yours is storing it in the UGPART dataset instead.

At NX9, the raster format was changed from .jpg to .png which has caused some viewer issues but can be changed back to the old behavior by using "set UGII_CGM_RASTER_ELEMENT=rle_cell" in nxtocgmdirect.bat.

A more popular approach is to convert the cgm to pdf and store the PDF by changing the arguments to export_ugdwgimages.exe:
"%UGII_BASE_DIR%\Ugmanager\export_ugdwgimages.exe" -all -text=text -pdf -nocgm %*
This will create a CGM then convert to PDF and throw away the CGM.


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: How to set where the translated dataset is placed?

Sorry... I've explained wrong.
The CGM is stored in a DrawingSheet, but this DrawingSheet is under of UGMASTER/UGPART, and I want this DrawingSheet at the ItemRevision level.

Re: How to set where the translated dataset is placed?

Re: How to set where the translated dataset is placed?

This is controlled by removing DrawingSheet (and/or DirectModel) value from three preferences that contain UGMASTER, UGPART and UGALTREP in their names. I don't have time to look up the actual prefs right now but will try and circle back later. Let me know if you find it so that I don't duplicate.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: How to set where the translated dataset is placed?

Okay. I've had a little free time to find the solution in my black bag of tricks. The secret to removing the DirectModel dataset from underneath the UGMASTER is to remove the IMAN_Rendering value from:
UGMASTER_DefaultChildProperties
UGPART_DefaultChildProperties
UGALTREP_DefaultChildProperties

If you select the UGPART dataset and then the Details tab you should be able to see the relation type for Sheet 1. Remove that relation type name from UGPART_DefaultChildProperties and Sheet 1 should be placed under the ItemRevision instead of under the UGPART dataset.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2