Cancel
Showing results for 
Search instead for 
Did you mean: 

Kerberos for AWC`

Valued Contributor
Valued Contributor

Hi,

 

We have implemented Kerberos authentication for TC11.6.0.2. It works for 4 -tier and thin client but it does't work for AWC4.1. Any idea how to configure it?

 

Please let me know in case you are looking for specific information.

 

Thanks,

Rupesh

11 REPLIES 11

Re: Kerberos for AWC`

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Have you tried a different browser? IE doesn't support it.
https://docs.plm.automation.siemens.com/tdoc/tc/12.1/help/#uid:xid1256814:index_tss00001:id261951:xi...
I like using Chrome for AWC.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Kerberos for AWC`

Valued Contributor
Valued Contributor
Hi,

Yes, I tried IE and Chrome but it doesn't work. Do you want to check any specific thing?

Best Regards,
Rupesh Samant

This e-mail is confidential and it is intended only for the addressees. Any review, dissemination, distribution, or copying of this message by persons or entities other than the intended recipient is prohibited. If you have received this e-mail in error, kindly notify us immediately by telephone or e-mail and delete the message from your system. The sender does not accept liability for any errors or omissions in the contents of this message which may arise as a result of the e-mail transmission.

Re: Kerberos for AWC`

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
I believe Tc11.6 still uses INSWEB to build the Identity Service? When configuring the Identity Service, and modifying the Application Registry table, you removed all lines except the TCSSOLoginService (and changed LDAP UserName Attribute to sAMAccountName) then add a row for Application ID "TC" but did you add another row for Application ID "AW"?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Kerberos for AWC`

Valued Contributor
Valued Contributor

Hello @RandyEllsworth 

 

Can you check attached insweb config and let me know if anything missing there?

 

BR,

Rupesh

 

Re: Kerberos for AWC`

Legend
Legend

Hi,

did you update your Active Workspace client settings?

Through TEM --> Update Active Workspace Client settings --> Enable TcSS Support

 

Re: Kerberos for AWC`

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor

Good question @Roman65.

@rupeshs, our tables look very different.


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Kerberos for AWC`

Siemens Phenom Siemens Phenom
Siemens Phenom
another question would be if the servermanager knows about those two application IDs...
since it was removed from the screenshot - why the need of two application IDs? running AWC on a different webserver? or running AWC on a different port on the same server?
is it J2EE or .NET?

Re: Kerberos for AWC`

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
TC (tc.war) and AW (awc.war) require two separate application ID's. Although Rupesh had some strange names SMC_TC_EMEA_DEV* for the Application ID.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Kerberos for AWC`

Siemens Phenom Siemens Phenom
Siemens Phenom
I have a few small implementations where tc.war and awc.war are on the same Tomcat - there I used only one application ID... is it somewhere in the DOCs that you have to use two separate AppIDs?
What kind of error message does @rupeshs get when trying to log in?