cancel
Showing results for 
Search instead for 
Did you mean: 

Login Errors After Server Modification: "Unable to load/refresh object"

This is an issue I seem to run into extremely often. Any time the Teamcenter server is modified, I always have issues logging in from a pre-existing client:

tc-login-errors.png

In the past, the steps I have taken to resolve this are to delete the C:\users\<user>\Teamcenter and C:\users\<user>\Seimens directories. However today removing those directories is not resolving anything.

 

Are there best practices or known steps to take after adding serverside packages? (By the way, the software I installed on the server was the CATIA V5 Integration).

8 REPLIES

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

You may need to regenerate the "client meta cache" after making datamodel changes. Running the following utils will force the regeneration:

 

generate_client_meta_cache -u=infodba -p=infodba -g=dba -t delete all

generate_metadata_cache -u=infodba -p=infodba -g=dba -force

generate_client_meta_cache -u=infodba -p=infodba -g=dba -t generate all

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Thanks for the suggestions. I was getting so fed up yesterday that I reverted the Teamcenter server to a point before installing the CV5 integration, but still got the same error.

 

I cleared the cache on the client

I made sure the FSC Service was running on the server

I made sure the FCC was running on the client via the fccstat command

 

Just for kicks I tried your suggestion as well, but no luck. This is driving me crazy and I don't even know the first place to look. Are there certain logs I should be checking?

 

Any help would be much appreciated.

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor
Can you check following variable value in your environment. We had similar issues, we renamed NG folder (your case it will be a different folder / path) and created same NG folder again on location to fix the issue. Just give a try.

TC_TMP_DIR=C:\Users\Public\NG\tmp
CATIA_WORK_DIR=C:\Users\Public\NG\tmp\tcic
TcExportDir=C:\Users\Public\NG\tmp

Thanks.

**************************************************************************************************************************************************
Email Disclaimer:

Information contained and transmitted by this e-mail (including any attachments) is confidential, proprietary and legally privileged data of Tata Technologies that is intended for use only by the addressee. If you are not the intended recipient, you are notified that any review, use, dissemination, distribution, copying or printing of this e-mail is strictly prohibited. You are requested to delete this e-mail or any copies immediately and notify the sender by reply email. Internet communications cannot be guaranteed to be timely, secure, error or virus-free. Tata Technologies does not accept any liability for virus infected email or errors or omissions or consequences which may arise as a result of this e-mail transmission. To know more about Tata Technologies please visit http://www.tatatechnologies.com
***********************************************************************************************************************************************
Sandip

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

You can review the tcserver syslog for clues. Regenerating the client cache should have fixed this error. The next thing to do is delete shared memory which may be stale. For this you'll have to stop all services and processes before you can delete the folder where the *.mem files reside. By default, this will be in infodba's USERPROFILE\Local Settings\Temp\V<maj_ver>.<min_ver>.X. Look for TC_SHARED_MEMORY_DIR in the tcserver syslog.

 

Here's a process I follow:

  • Shutdown services/processes. Remote servers then web/app servers.
  • Run: clearlocks -assert_all_dead
  • Run: install -lock_db
  • Task (Tc9.1 or Tc10.1): Modify TC_DATA\tc_profilevars.bat. Use SFB to disable pref shared mem using TC_USE_PREFS_SHARED_MEMORY=FALSE
  • Task: Delete TC_SHARED_MEMORY_DIR. On pool manager server, Run: generate_metadata_cache -force
  • Optional: clean up old logs. General server cleanup.
  • Run: install -unlock_db
  • Startup services/processes. app/web servers (Test webclient login). remote servers (Test rich client login).

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Login Errors After Server Modification: "Unable to load/refresh object"

*sigh* still no luck. I tried all the steps you mentioned and also set some additional variables i saw here: http://wiki.plmjobmanager.com/doku.php?id=cap01:nxtcsettings#disable_tc_shared_memory_dir_new1202201...

 

I've attached the tcserver.exe syslog from the client machine...there are several ClientCache errors that get printed out 

 

ERROR - 2015/3/10-20:21:05.270 UTC - NewWindows7_1.00659.01.administrator.00002 - 27026 - +++ClientCacheManager::removeInvalidObjects failed. 

ERROR - 2015/3/10-20:21:05.280 UTC - NewWindows7_1.00659.01.administrator.00002 - 27026 - +++ClientCacheManager::initialize Failed with ifail 27026.

ERROR - 2015/3/10-20:21:05.289 UTC - NewWindows7_1.00659.01.administrator.00002 - 27026 - +++ClientCacheManager:getClientCache failed 
 - Teamcenter.ClientFramework.clientcache at D:\workdir\tc101w0604_64\src\core\clientcache\ClientCacheManager.cxx(1000)

 There are some others too...I've attached the syslog in case that helps.

 

If I'm on the server I can run the client fine. The syslog that it puts out has no errors in it. This is so frustrating. Thanks for the suggestions so far, though.

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

I guess we all assumed that you were running a 4 tier environment with a 4t rich client. Hence, all the advice for rebuilding the client cache on the server. After reviewing your syslog, I see you are actually running a 2 tier rich client. 2 tier means that your laptop/workstation is performing both the client AND the server functions while negotiating with database. This also means that the problem is actually on this laptop/workstation and not on a server somewhere.

 

There are special considerations for running 2 tier rich clients to ensure that TC_ROOT is updated correctly. You obviously have a good TC_ROOT on the server since you're able to run Tc. The same changes you made on the server need to also be changed on this client (I'm mainly talking about TC_ROOT\bin, TC_ROOT\install, TC_ROOT\lang, etc.).

 

The tcserver syslog shows that you have a "rouge" folder in the ClientCache folder on your machine and that it doesn't have write access to remove it.

 

Gory details

First stack dump

  • 1143 - Could not load the Entry Point Function Ptr <libtxd_register_callbacks> for the Custom Library <libtxd>

Second error

  • 33184 - +++ClientCacheManager::initialize Encountered rouge folder ContextMenuSuppressionRulesCache in cache folder.

 

Third error

  • 27026 - +++ClientCacheManager::removeInvalidObjects failed.

 

The trick is finding the ClientCache folder and then either deleting it or granting write access. Try stopping any running Teamcenter session (including TAO and java) then delete the contents of:

C:\Users\PTCUSE~1\AppData\Local\Temp

 

You have some other strangeness in your syslog due to "PTC_User" somehow replacing the underscore with a space in the path for the transient volume "PTC User2TierTransientVolume"... but it seems to write ok:

 

NOTE  - 2015/3/10-20:20:52.026 UTC - NoId - MetadataCache: Using Local memory !!! - Teamcenter.MetaModel.sharedcache at D:\workdir\tc101w0604_64\src\core\sharedcache\MetadataCache.cxx(117)
NOTE  - 2015/3/10-20:20:53.021 UTC - NewWindows7_1.01448 - TC_TMP_DIR environment variable not found. - Teamcenter.Organization.sa at D:\workdir\tc101w0604_64\src\core\sa\filetickets.cxx(1129)
NOTE  - 2015/3/10-20:20:53.023 UTC - NewWindows7_1.01448 - Created the Transient Volume Root Directory at C:\Users\PTCUSE~1\AppData\Local\Temp\PTC User2TierTransientVolume. - Teamcenter.Organization.sa at D:\workdir\tc101w0604_64\src\core\sa\filetickets.cxx(4791)
NOTE  - 2015/3/10-20:20:53.025 UTC - NewWindows7_1.01448 - Transient volume write access verified using file: C:\Users\PTCUSE~1\AppData\Local\Temp\PTC User2TierTransientVolume\tvrdtestfile_3464_1426018853 - Teamcenter.Organization.sa at D:\workdir\tc101w0604_64\src\core\sa\filetickets.cxx(4851)
NOTE  - 2015/3/10-20:20:53.025 UTC - NewWindows7_1.01448 - The Transient Volume Root Directory is C:\Users\PTCUSE~1\AppData\Local\Temp\PTC User2TierTransientVolume  - Teamcenter.Organization.sa at D:\workdir\tc101w0604_64\src\core\sa\filetickets.cxx(1257)
WARN  - 2015/3/10-20:20:59.031 UTC - NewWindows7_1.01448 - Error while reading Tc Server Monitoring configuration.  Cannot Open TcServer Health Monitoring Config File. It may be locked by another process - Teamcenter.MLD.Monitoring

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Login Errors After Server Modification: "Unable to load/refresh object"

So this finally got resolved after an offshore resource familiar with Teamcenter logged into the system remotely and took a look. He replied with the following:

 

As you already described that you have tried cleaning the cache  but it was not working, so I tried to login with a different user to check if it’s an issue with some specific user or for all the users in the system & I was able to login with ‘infodba’ user. Then I checked the organization to see the user status & there I found that the default volume field was blank. So I allocated the default volume to it & the issue was resolved.

 

 

I'm not 100% sure that the "default volume" thing was the issue, though. After he fixed the client, I proceeded to install the Teamcenter Integration for CATIA again and then ran into the same problem! However this time, I logged into the rich client using the "infodba" account and immediately saw a "Synchronizing teamcenter client with server" (or something like that) popup. Afterwards, I logged out then logged back in with the Administrator account and everything worked.

 

Does this make sense? Why would logging in with a different account fix things client-side for my main account?

 

Anyways, thanks for all the help and suggestions. This has certainly been a frustrating ordeal.

 

Re: Login Errors After Server Modification: "Unable to load/refresh object"

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

You shouldn't need to define a default volume for the user, only a default group which has a default volume. Specifying a default volume for the user will create a sub-folder in the volume with the users name where files will be stored and can lead to issues where the user is deactivated but cannot be deleted (due to "references").

 

The problem sounds like its related to inconsistencies in the FMS Master and Teamcenter preferences or possibly permissions accessing the transient volume.

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2